Realsense T265 not being recognized as an USB3.0 Device.

DanielPalominoSDanielPalominoS New Member Posts: 7
edited September 7 in UP board Troubleshooting

Greetings,
I'm having some issues when connecting a Realsense T265 on the USB 3.0 OTG port. If I run either realsense-viewer or lsusb -v, both show that camera is being detected as if it where connected to an USB 2.1 port, when actually is connected to the USB 3.0 port.
Since I don't have USB3.0 micro b to USB3.0 micro b, we have to use one USB3.0 micro b to male USB 3.0 Type A, which is then connected to a female Type A USB 3.0 (or OTG) to USB3.0 micro b. We don't think this being the problem, since just all are 3.0 cables and distance is not long, and a few days ago everything was working just fine.
Do anyone have any clue on what could be happening, perhaps some issue with the drivers?

Thank you in advance.

Comments

  • DCleriDCleri Administrator, AAEON Posts: 1,058 admin

    sometimes the problem can occur when plugging the USB3.0 device and the detection might take longer then expected (so it switches to USB2).

    Try to connect the camera and then connect the power cable to power up the board.

  • DanielPalominoSDanielPalominoS New Member Posts: 7

    Hi @DCleri I will give it a try and see what happens.
    Thank you for your help.

  • DanielPalominoSDanielPalominoS New Member Posts: 7

    Hello @DCleri I tried connecting the camera before powering the board on, as you suggusted, but did not work :/ .
    I also try connecting the camera after the module has been powered on, but did not work either.
    I find an article published by Intel) where they provide some suggestions when this situation happens. I try all of them and still no luck.
    There are other SBCs we can test with and none of this has this issue. The only thing that is different from the UP board is the type of connector and the addittional cable I menctioned before, but since we do not have any USB3.0 micro b to USB3.0 micro b and since locally there are no sellers for this type of cable we cannot confirm this being what causes the problem. Altough I know UP sells this cable, this is not an option at the moment since it implies to import it and shipment and fee for a single cable is not worthy.
    As addittional information I could say that we are running on ubuntu 18.04, with the 4.15 kernel since the 5.0.0 seems to have a proublem that does not allow the UP-board to reboot nor shutdown (Press the power button for 5 sec is the only way to turn it off). Perhaps is something realted to the O.S which is causing the compatibility issues with the camera?

  • DCleriDCleri Administrator, AAEON Posts: 1,058 admin

    Hi Daniel,

    Can you detect the camera as UBS2.0 device or not at all?

    There is a workaround for the reboot issue on kernel 5 here:

    about the detection, it is most likely the adapter then. Unfortunately we cannot test all and we have few ones which we have tested and they are available from our shop (depending on your use case):
    https://up-shop.org/usb3-0-adapter-micro-b-male-to-a-female.html
    https://up-shop.org/usb3-0-otg-cable.html
    https://up-shop.org/usb3-0-microb-to-microb-cable.html

  • DanielPalominoSDanielPalominoS New Member Posts: 7

    Hi @DCleri,
    The camera is detected as USB2.0, no matter which port is used, but this implies that one cannot retrieve all the information provided by the camera, or at least not in a reliable manner.

    Regarding the reboot, you may forget to put the link, but it is good to know that there is already a workaround though. I guess it is not difficult to find it.

    The connection uses a regular USB3.0 microb cable (somithing like this https://www.amazon.com/AmazonBasics-USB-3-0-Cable-Male/dp/B00NH13G5A), and then is connected to an adapter similar to the one that is available in the second link you sent.
    If we have the chance to get a cable like the one in the third link we will let you know if this solves the problem.

    Thank you again for your assistance, it's been great.

  • DCleriDCleri Administrator, AAEON Posts: 1,058 admin

    the problem is with the adapter.
    My suggestion is to use the last cable I sent you so you won't need any adapter and it should detect the camera as USB3.0: https://up-shop.org/usb3-0-microb-to-microb-cable.html

Sign In or Register to comment.