This is the area to clarify hardware specification if there's anything unclear from the datasheet. If the specification is software related, please ask in the related software section.

UP squared board won't boot and no blue LED on(Hardware may be broken)

chenhan0120chenhan0120 New Member Posts: 1

Hi, I have ordered a UP squared board recently. It has been working well and it is connected with a battery(It is fixed on my drone and share its battery). A few days ago, when I unplug the battery and plug in a power converter(5V,4A) from the power socket in the room, the monitor connected to it shew nothing unless "no signal". After a few seconds, it is smoking and I cut off the power immediately, one spot on the board is very hot. After about 20 minutes, I use another 5V 4A power converter only a blue LED is on and stable when I plug in the power cable. I have tried several times to remove the coin battery and that didn't work.

Today, I tried the converter which caused smoking, the board smoke again. Then I connected another converter, no LED is on. I guess maybe some Components of the board are broken, though the board seems perfectly normal from the outside.
Can you help me to fix this? Thank you!

Best Answer

Sign In or Register to comment.