UP board will not boot after bios update

Hello. I have been using my UP board successfully for quite some time now, with Windows 10 for an indoor kiosk. However, as the kiosk went EOL I tried repurposing the UP board for Android use. I tried with a Phoenix OS bootable USB stick but the board freezed constantly before even beginning to install. So I thought a bios update would sort things out. I was so wrong!
I've proceeded as instructed in the website. I updated first to UPC1DM11 version (my board is 4GB RAM version). All went smooth, and the board booted happily with DM11. Then I went for the second step, UPC1DM17 upgrade. The upgrade went smooth as before. The board rebooted and ... nothing. No image on HDMI. SO far I've tried everything I could, but of no avail.
I started with a different power source. The original one was 5V 3A so I went straight to my bench PSU of 5V 10A. It didn't help. I tried resetting the BIOS settings by disconnecting the power supply and the BIOS battery. One hour later, nothing. The board powers up, the blue led turns on and that's it. It draws around 0.5-0.7 Amps from the PSU, if that info might be of any use... If I power it with a USB stick attached (I have a rare one that still retains the activity led) the stick LED flashes a few times soon after the blue led turns on, but that's it.
So, right now I am very upset for breaking the board! The warranty must be off as the boards is pretty old, so RMA is out of the question.
Can someone suggest a solution to this? I would try even advanced procedures as manual reflashing stuff with direct pin connection (as I have access to pretty advanced equipment) if that would help... But I don't know where to start!

Comments

  • DCleriDCleri Administrator, AAEON Posts: 993 admin

    Hi @Laurentiu Badescu

    I am not sure what happened there, but BIOS updates can go wrong and it can happen if there is anything wrong at power level.
    From what I can see during the update you used a PSU which is lower specs than advised which may have left the BIOS in a unknown state.

    We have described the procedure to re-flash the BIOS for UP and UP Squared using SF-100 dediprog and a clip, you can check out all the steps from our wiki: https://wiki.up-community.org/BIOS_chip_flashing

Sign In or Register to comment.