[SOLVED] Problem with bringing LoRa server on UPSquared Edge Computer

vpodolskiyvpodolskiy New Member Posts: 3
edited October 8 in UP Squared Linux

Hi,

Recently, we've bought LoRa Edge computer (https://up-shop.org/up-systems/292-up-squared-lora-edge-computing.html) for an edge computing course at our university. Linux boots fine and everything runs, but all the attempts to get LoRaServer (https://www.loraserver.io/) to accept the messages from the end device fail - no LoRaWAN frames are visible to the server. When digging deeper, I've understood that there is no LoRa gateway software preinstalled as well as no packet-forwarder. I've tried to install the needed software (lora-gateway and packet-forwarder) by compiling it both with default options and options that were provided in SOME manuals on UP products (e.g. in the manual on this particular product there are no instructions); unfortunately, all the attempts failed. The problem is not on the end device side and not on the LoRa server side as the end device worked perfectly with the TTN gateway and was then adapted strictly according to the instructions for LoRa server.

Could someone kindly point me to an up-to-date user guide that contains proven instructions for deployment of the LoRaWAN server and/or gateway on UPsquared edge?

Best regards,
Vladimir

Comments

  • DCleriDCleri Administrator, AAEON Posts: 703 admin

    Hi @vpodolskiy

    Thanks for your feedback, we will include these instruction in the community shortly.

    First it is necessary to follow those steps to install Ubuntu 16.04 and the right kernel:
    https://wiki.up-community.org/Ubuntu#Ubuntu_16.04_installation_and_configuration
    Please use the Desktop version and also follow the steps 1.1 until 1.2 included only.

    Once the installation is complete, boot the system and follow these steps to enable the SPI interface used by the LoRa module:
    https://wiki.up-community.org/Pinout_UP2#Installing_ACPI_overrides_to_enable_spi_in_userspace

    Reboot the system.

    If you want to connect to a LoRa public or private server and have the device acting as gateway only, you should configure the LoRa concentrator using our github repositories for:
    https://github.com/AAEONAEU-SW/lora_gateway/tree/up_squared
    https://github.com/AAEONAEU-SW/packet_forwarder

    These repositories are a fork with the necessary modification to enable the LoRa concentrator on our system.
    Create a folder (e.g. lora) and download both repositories. Inside the folder you should have:
    lora_gateway
    packet_forwarder

    Please make sure the folders have those exact names.
    Enter in lora_gateway and run:
    make clean && make
    Then enter in the packet_forwarder folder and run:
    make clean && make

    Now inside lora_gateway folder you should execute the command:
    sudo ./reset_lgw.sh start
    Then from the packet_forwarder you should configure it according to your Network server requirements, then you can run the packet forwarder.
    On top of the lora gateway and packet forwarder packages you can install the additional software.

    To run the packet forwarder after you configured it according to your setup, inside the packet_forwarder/lora_pkt_fwd folder simply run:
    sudo ./lora pkt_fwd

  • vpodolskiyvpodolskiy New Member Posts: 3

    @DCleri said:
    Hi @vpodolskiy

    Thanks for your feedback, we will include these instruction in the community shortly.

    First it is necessary to follow those steps to install Ubuntu 16.04 and the right kernel:
    https://wiki.up-community.org/Ubuntu#Ubuntu_16.04_installation_and_configuration
    Please use the Desktop version and also follow the steps 1.1 until 1.2 included only.

    Once the installation is complete, boot the system and follow these steps to enable the SPI interface used by the LoRa module:
    https://wiki.up-community.org/Pinout_UP2#Installing_ACPI_overrides_to_enable_spi_in_userspace

    Reboot the system.

    If you want to connect to a LoRa public or private server and have the device acting as gateway only, you should configure the LoRa concentrator using our github repositories for:
    https://github.com/AAEONAEU-SW/lora_gateway/tree/up_squared
    https://github.com/AAEONAEU-SW/packet_forwarder

    These repositories are a fork with the necessary modification to enable the LoRa concentrator on our system.
    Create a folder (e.g. lora) and download both repositories. Inside the folder you should have:
    lora_gateway
    packet_forwarder

    Please make sure the folders have those exact names.
    Enter in lora_gateway and run:
    make clean && make
    Then enter in the packet_forwarder folder and run:
    make clean && make

    Now inside lora_gateway folder you should execute the command:
    sudo ./reset_lgw.sh start
    Then from the packet_forwarder you should configure it according to your Network server requirements, then you can run the packet forwarder.
    On top of the lora gateway and packet forwarder packages you can install the additional software.

    To run the packet forwarder after you configured it according to your setup, inside the packet_forwarder/lora_pkt_fwd folder simply run:
    sudo ./lora pkt_fwd

    Hi and thanks for the answer!

    I've tried this procedure, but still no success.
    LoRa packet forwarder outputs “ERROR: failed to start the concentrator”.
    Testing with utils from lora_gateway folder (e.g. util_spi_stress) results in error “ERROR: lgw_connect() did not return SUCCESS”.

    Any suggestions to a potential culprit that I could further test?

  • DCleriDCleri Administrator, AAEON Posts: 703 admin

    the ACPI override for SPI were not installed correctly.

    Can you see them from your terminal?

    $ ls /dev/spidev*

    What is the output of that command?

  • vpodolskiyvpodolskiy New Member Posts: 3
    edited October 7

    @DCleri said:
    the ACPI override for SPI were not installed correctly.

    Can you see them from your terminal?

    $ ls /dev/spidev*

    What is the output of that command?

    Thanks for your support! The issue is resolved.
    I do not know what exactly helped, but I did the following:
    1. updgraded OS with the following reboot
    2. executed everything that you describe above with sudo (previously I've used it only for the reset_lgw.sh script).

    I'd advise to add that to instructions as well.

    cheers!

Sign In or Register to comment.