ubuntu 18.04 - no audio device listed

toko789toko789 New Member Posts: 11

Hi there,

my UP board runs perfectly Ubuntu 18.04. I did install as well the fix for file /etc/pulse/default.pa like given as hint in the wiki.

However, when I open settings of Ubuntu and go to "Sound" I have still no device listed there. I try to get the Audio via the HDMI cable.

I'm sure you got that working. So those of you: could you pls help and tell me what's needed??
Thx in advance!!

thomas

Best Answer

Answers

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 348 admin

    Hi @toko789 ,

    You could check your HDMI devices here:
    $ dmesg | grep HDMI
    or
    $ sudo aplay -l

  • toko789toko789 New Member Posts: 11

    hey ccalde, thx very much for you reaction.

    dmesg:

    [email protected]:~# dmesg | grep HDMI
    [    0.048318] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
    [    5.094702] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=0 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input5
    [    5.101850] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=1 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input6
    [    5.102018] input: Intel HDMI/DP LPE Audio HDMI/DP,pcm=2 as /devices/pci0000:00/0000:00:02.0/hdmi-lpe-audio/sound/card0/input7
    

    however at the end I get as well
    [ 4.421692] [drm] HDaudio controller not detected, using LPE audio instead

    and tons of lines like:
    Audio Port: ASoC: no backend DAIs enabled for Audio Port

    and aplay lists:
    [email protected]:~# aplay -l
    **** Liste der Hardware-Geräte (PLAYBACK) ****
    Karte 0: Audio [Intel HDMI/DP LPE Audio], Gerät 0: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 0: Audio [Intel HDMI/DP LPE Audio], Gerät 1: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 0: Audio [Intel HDMI/DP LPE Audio], Gerät 2: HdmiLpeAudio [Intel HDMI/DP LPE Audio]
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 1: bytchtnocodec [bytcht-nocodec], Gerät 0: Audio () []
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0
    Karte 1: bytchtnocodec [bytcht-nocodec], Gerät 1: Deep-Buffer Audio (
    ) []
    Sub-Geräte: 1/1
    Sub-Gerät #0: subdevice #0

    so there are devices listed and as well errors, but however in ubuntu 18.04 sound settings I still have none listed, and , well what's really the problem: I get no sound out of HDMI (BIOS settings are correct... I had before ubilinux installed on same board where sound did work flawlessly). Hope anybody finds any hint in this output?

  • toko789toko789 New Member Posts: 11

    @ccalde - you have maybe ANY idea?

  • toko789toko789 New Member Posts: 11
    edited September 26

    or ANYBODY else?

  • DCleriDCleri Administrator, AAEON Posts: 699 admin

    Can you check in the BIOS if you have the boot settings for Windows or Linux/Android?

    Also, just in case, try to reset the BIOS settings to default and then try again.

Sign In or Register to comment.