Can't flash with external SPI programmer

fuzzfuzz New Member Posts: 4
edited September 8 in UP Squared BIOS & FPGA

I flashed coreboot onto my N4200 UP^2, and it's stuck in a loop.

My problem now is that I'm no longer able to flash the chip using an external programmer (Terasic USB blaster) and flashrom.

I can occasionally get flashrom to detect the chip and start erasing, but the SoC is interfering with the SPI communications.

I've also tried using an external power supply to provide the 1.8V to the flash chip, and it is able to detect and read the chip without issue, but the enable write command isn't setting the WEL bit in the status register. Lowering the supply voltage causes WEL to be set but erase fails, which tells me the external supply is likely powering up some portions of chips on the board which are messing with the SPI signals as well.

Is there any way to hold the SoC in reset so it will let me flash this chip? With the original BIOS, I could use the power button to turn it off (blue light was off, flash was provided with 1.8v from the board, and flashrom worked perfectly fine to read, erase, write but now I can't get the SoC to power off.

I've tried putting a jumper on the reset pin headers, as well as the power button pins and they didn't help.

I'm trying to avoid desoldering the chip, but I will if I have to :)

Comments

Sign In or Register to comment.