[SOLVED] Openvino Installation on Realsense Robotics Kit fails for AI Core X Myriad Step

tjirschtjirsch New Member Posts: 7
edited September 3 in UP Squared Linux

I received my robotics kit without a preinstalled ubuntu image. The installation doc given with the AI Core X product (https://up-shop.org/featured/261-up-ai-core-x.html) does not work, because the 2018 R5 download of the Openvino Toolkit is no longer available.
All Openvino Toolkit installations from 2019 fail within the sidestep: http://docs.openvinotoolkit.org/latest/_docs_install_guides_installing_openvino_linux_ivad_vpu.html
when running sudo ./setup.sh make fails and no drivers get compiled.

What am I to do ?

NB:
I tried to create this in Starter Kits->Intel Realsense Robotics Development Kit category but that wsa not selectable.

Comments

  • tjirschtjirsch New Member Posts: 7

    I have installed the latest 2019 released again.
    running ./demo_squeezenet_download_convert_run.sh -d MYRIAD
    produces:

    ...
    Run Inference Engine classification sample

    Run ./classification_sample_async -d MYRIAD -i /opt/intel/openvino/deployment_tools/demo/car.png -m /home/thomas/openvino_models/ir/FP16//classification/squeezenet/1.1/caffe/squeezenet1.1.xml

    [ INFO ] InferenceEngine:
    API version ............ 2.0
    Build .................. custom_releases/2019/R2_f5827d4773ebbe727c9acac5f007f7d94dd4be4e
    Description ....... API
    [ INFO ] Parsing input parameters
    [ INFO ] Parsing input parameters
    [ INFO ] Files were added: 1
    [ INFO ] /opt/intel/openvino/deployment_tools/demo/car.png
    [ INFO ] Creating Inference Engine
    MYRIAD
    myriadPlugin version ......... 2.0
    Build ........... 27579

    [ INFO ] Loading network files
    [ INFO ] Preparing input blobs
    [ WARNING ] Image is resized from (787, 259) to (227, 227)
    [ INFO ] Batch size is 1
    [ INFO ] Loading model to the device
    [ ERROR ] Can not init Myriad device: NC_ERROR
    Error on or near line 238; exiting with status 1

    lsusb finds Bus 004 Device 002: ID 03e7:f63b

    running ./demo_squeezenet_download_convert_run.sh is ok.

  • tjirschtjirsch New Member Posts: 7

    My AI Core X is now working. I installed Intel Openvino Distribution 2019 R2.01 and also did the steps for the "Steps for Intel® Movidius™ Neural Compute Stick and Intel® Neural Compute Stick 2".
    After that, all demos worked with the -d MYRIAD option.
    I thought that the AI Core X module could not be a usb device because of the mpcie Connector, so I never followed the steps in the above section. This could be clarified in the documentation.
    I did not try to use the HDDL option / installation.

    Thanks again for the support !

Sign In or Register to comment.