Recognizing Large Drives

jwhh91jwhh91 New Member Posts: 2

Hello,

I've tried both Ubuntu and Ubilinux, and I haven't been able to get a drive of 1 TB or larger recognized on either USB 2.0 or 3.0. These drives work fine on other machines, but they don't show up under "sudo fdisk -l" on the up-board. One of the drives is powered, so that's ruled out. Am I missing something?

Comments

  • DCleriDCleri Administrator, AAEON Posts: 703 admin

    have you tried the command lshw ("sudo lshw")?

    What kernel version are you using on Ubuntu and which version of Ubuntu?

  • jwhh91jwhh91 New Member Posts: 2

    Thanks for the reply. The board currently has Ubilinux installed, and I've had apt do a full upgrade. I had run Lubuntu 18.04 for a while, but apt wasn't finding the kernel package for 18.04 after adding the PPA and updating. Tinkering with Linux is how I afford food, but maybe I missed something there.

    As a correction to my original post, I have found that both drives are recognized on USB 2.0, but like before, neither drive will show up on USB 3.0 via fdisk, lshw, or gparted when initially plugged in and also after a reboot. I also tried using a powered USB 3.0 hub to no avail. The board has no issue recognizing a 128 GB flash drive on USB 3.0, so I'm just at a loss on how to proceed. Is there a known work-around or anything else to be done as far as troubleshooting?

  • DCleriDCleri Administrator, AAEON Posts: 703 admin

    Hi @jwhh91 ,

    I would suggest to check what BIOS version you have installed and if necessary, upgrade to the latest version: https://downloads.up-community.org/download/up-board-uefi-bios-upc1dm17/

    For Ubuntu please make sure you follow the procedure from our wiki: https://wiki.up-community.org/Ubuntu#Ubuntu_18.04_installation_and_configuration

    The PPA works correctly and you should be able to install the dedicated kernel easily.

    About the detection, once it is everything up to date, make sure you connect the drive before booting the system, sometimes it can be an hot plug detection issue.
    Also you can try a different USB3.0 cable, some cables/adapters do not work well with the microUSB3.0 port.

    If you need an adapter from USB3.0 to micro USB3.0, I would suggest to get one of the tested adapters from our shop

Sign In or Register to comment.