[SOLVED] Disable PWM function at startup

JvvJvv New Member Posts: 4
edited June 2019 in UP Squared Linux

Hi,

I am using the UP^2 with Ubuntu 18.04.2 LTS. The kernel used is 4.15.0 . This is the result of uname -a : 4.15.0-37-generic #40~upboard04-Ubuntu.

I saw on the wiki that on system start, all the pins are configured in function mode.

On UP^2 at system start all the pin in the hat connector are configured in function mode.

I use the physical pin 16 ( Linux gpio 471). This pin function is PWM3, so at system startup, the output of the pin is a squared signal at a frequency of ~100Hz (measured with a scope). I don't want to use PWM so I made a script that will be launched at system start and basically it is exporting the gpio 471, set its direction to out and value to 0. The issue is that at system start, it takes about 30seconds to launch my script. So during 30 seconds the pin 16 outputs a squared signal before going to 0V (when my script is executed).

This behavior is really bad for my usage. It is a bit difficult for me to use another pin so before doing that i wanted to know if there is a way to completly disable the PWM3 function at system start?

Regards,
Jvv

Tagged:

Comments

Sign In or Register to comment.

Tagged