Kernel Installation Issue

lowjunenlowjunen New Member Posts: 5

Hello folks,

Looking for some help on the kernel installation. Installation worked out fine on a previous UpBoard I was using a few months back. But I'm having issues on my second board.

I followed the exact steps in
https://wiki.up-community.org/Ubuntu#Install_Ubuntu_kernel_for_UP_from_PPA

and also augmented it with the instructions from @ccalde in
https://forum.up-community.org/discussion/comment/9258#Comment_9258

In both cases, on reboot after kernel installation, I get the error
"ALERT! UUID=6a32b157-fe05-4c8c-9c7c-c8fadce09770 does not exist. Dropping to a shell!

So I'm stuck with a single terminal (no GUI) with (initramfs).

Some things to note... when removing the generic kernel, the dpkg failed to remove one of the packages. I didn't take down the exact number unfortunately but I can replicate it again if need be. To workaround this, I have tried ignoring it and force removing it. In both cases, to install the UpBoard kernel, I had to do a 'sudo apt-get install -f' first as the dependencies were missing.

Thanks!

Tagged:

Comments

  • Al BeeAl Bee New Member Posts: 6

    @lowjunen I'm experiencing the same exact issue you described, were you able to resolved it?

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 331 admin

    Hi @lowjunen ,

    Could you please provide the full log for your installation using the Ubuntu kernel instruction from the Wiki?

  • lowjunenlowjunen New Member Posts: 5

    Hey @ccalde. Sorry if this is a dumb question but how would one go about doing that? Are you referring to the messages published in between the terminal commands?

    @Al Bee No but I am trying out the alternative posted by @hoejhl in the second link though. I'll update to this thread accordingly.

  • lowjunenlowjunen New Member Posts: 5

    Purging configuration files for linux-modules-extra-4.15.0-50-generic (4.15.0-50.54~16.04.1) ...
    Removing linux-image-4.15.0-50-generic (4.15.0-50.54~16.04.1) ...
    E: Aborting removal of the running kernel
    dpkg: error processing package linux-image-4.15.0-50-generic (--purge):
    subprocess installed pre-removal script returned error exit status 1
    Removing linux-image-generic-hwe-16.04-upboard (4.15.0.37.5000~upboard2) ...
    Removing linux-modules-extra-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    Purging configuration files for linux-modules-extra-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    Removing linux-image-unsigned-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    I: /vmlinuz is now a symlink to boot/vmlinuz-4.15.0-50-generic
    I: /initrd.img is now a symlink to boot/initrd.img-4.15.0-50-generic
    /etc/kernel/postrm.d/initramfs-tools:
    update-initramfs: Deleting /boot/initrd.img-4.15.0-37-generic
    /etc/kernel/postrm.d/zz-update-grub:
    Generating grub configuration file ...
    Warning: Setting GRUB_TIMEOUT to a non-zero value when GRUB_HIDDEN_TIMEOUT is set is no longer supported.
    Found linux image: /boot/vmlinuz-4.15.0-50-generic
    Found initrd image: /boot/initrd.img-4.15.0-50-generic
    Adding boot menu entry for EFI firmware configuration
    done
    Purging configuration files for linux-image-unsigned-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    rmdir: failed to remove '/lib/modules/4.15.0-37-generic': Directory not empty
    Removing linux-modules-4.15.0-29-generic (4.15.0-29.31~16.04.1) ...
    Purging configuration files for linux-modules-4.15.0-29-generic (4.15.0-29.31~16.04.1) ...
    Removing linux-modules-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    Purging configuration files for linux-modules-4.15.0-37-generic (4.15.0-37.40~upboard03) ...
    Removing snapd-login-service (1.33-0ubuntu0.16.04.1) ...
    Purging configuration files for snapd-login-service (1.33-0ubuntu0.16.04.1) ...
    Removing thermald (1.5-2ubuntu4) ...
    Purging configuration files for thermald (1.5-2ubuntu4) ...
    dpkg: linux-modules-4.15.0-50-generic: dependency problems, but removing anyway as you requested:
    linux-image-4.15.0-50-generic depends on linux-modules-4.15.0-50-generic.

    Removing linux-modules-4.15.0-50-generic (4.15.0-50.54~16.04.1) ...
    Purging configuration files for linux-modules-4.15.0-50-generic (4.15.0-50.54~16.04.1) ...
    dpkg: warning: while removing linux-modules-4.15.0-50-generic, directory '/lib/modules/4.15.0-50-generic' not empty so not removed
    Processing triggers for initramfs-tools (0.122ubuntu8.14) ...
    update-initramfs: Generating /boot/initrd.img-4.15.0-50-generic
    depmod: WARNING: could not open /var/tmp/mkinitramfs_nyeK4g/lib/modules/4.15.0-50-generic/modules.order: No such file or directory
    depmod: WARNING: could not open /var/tmp/mkinitramfs_nyeK4g/lib/modules/4.15.0-50-generic/modules.builtin: No such file or directory
    Processing triggers for man-db (2.7.5-1) ...
    Processing triggers for dbus (1.10.6-1ubuntu3.3) ...
    Errors were encountered while processing:
    linux-image-4.15.0-50-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)

    This is the last from the terminal that I get when I remove the kernel. It seems like it's preventing me from removing the current kernel?

  • lowjunenlowjunen New Member Posts: 5

    New update. So... following what @hoejhl did did not work BUT...

    Going down the rabbit hole from the above log... I did a force removal of the running kernel using the instructions from https://askubuntu.com/questions/1089460/how-do-i-uninstall-the-running-kernel-by-command-only
    Then carried on with the rest of the steps on the wiki. So far so good. I'm no longer getting the single terminal on bootup and uname -a gives the right kernel.

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 331 admin

    Hi @lowjunen ,

    It looks like you have issues to remove the generic kernel, right?
    When you run the next command following the UP Wiki instructions:
    sudo apt-get autoremove --purge 'linux-.*generic'

    Did you confirm or abort to remove the kernels before install the UP supported kernel?

Sign In or Register to comment.