This is the area to clarify hardware specification if there's anything unclear from the datasheet. If the specification is software related, please ask in the related software section.

USB problem - no power(?) - UP Gateway ( ATOM x5-Z8350.w/4G memory,32G eMMC board)

Hi,

It appears I have no or limited power at the USB ports of one of my my four UP Gateways ( ATOM x5-Z8350.w/4G memory,32G eMMC board). I requested an RMA but was advised to check here first. It would be great if there was a solution to avoid the hassle of returning the unit.

The gateways are endpoints for home audio distribution. Three work perfectly - the fourth appears to have no (or low) voltage at it's USB ports. I found a post here in the hardware spec category from Dec. 2018 which appeared to have the same no USB power problem but the thread offered so solutions. I've ordered a USB port tester from Amazon to help verify the problem with specific numbers. What I've done so far...

Testing methodology:

  1. Exact same 5V power supply (only one I've used since the order arrived),
  2. Exact same outboard bus-powered DAC (iFi micro iDSD-BL - owners manual), and
  3. Exact same USB cable with each gateway.

Results:

On all three working gateways:

  1. DAC on / gateway power supply OFF = blinking green light on DAC which means "Awaiting USB connection"
  2. DAC on / gateway power supply ON = solid steady light on DAC (signal has been established).

On the problem gateway:

  1. DAC on / gateway power supply OFF = blinking green light
  2. DAC on / gateway power supply ON = blinking green light
    The USB connection is never acknowledged by the DAC. I have an older version of the same DAC (iFi micro iDSD (not BL)) and it's behavior is identical.

Similarly, I also tested 6 known working thumb drives. Their tiny indicator lights all illuminate properly with the three functioning gateways. One the problem one, none of the thumb lights ever goes on.

Thanks in advance for any insight.
Dave

Comments

  • doubledotdoubledot New Member Posts: 3

    USB tester arrived. Two photos attached. Top row of the attached tester shows voltage, second row is amperage.

    The unit with the VESA plate attached showing 5.0115v output is one of the three that are working.

    The other photo is of the one that has never worked. Attached DAC is on and the tiny green light blinks (trying to make a connection). Tester indicates there is either no power at the USB port or less than the 3.7V required for the tester to work.

    All cables and 5V power supply are the same. The power supply is the only 5V one I own that provides the correct amperage. Am waiting for resolution here before buying more.

  • DCleriDCleri Administrator, AAEON Posts: 592 admin

    Hi @doubledot

    Please make sure all the units has the same BIOS version.

    If the non-working one has an old BIOS, you can update with the latest one: https://downloads.up-community.org/download/up-board-uefi-bios-upc1dm15/

    From the tests you have done, and the fact that 3 units out of 4 works perfectly, it seems to me like a defective unit.

    Just do one more test with the latest BIOS and if still not working you can return the faulty unit.

    Thanks

  • doubledotdoubledot New Member Posts: 3

    Unlike the working units, I’m unable to check or install anything on the problem unit. Without USB power, it’s been impossible to use a keyboard, mouse or thumb drive - the unit does not acknowledge their existence. I followed the ‘no boot’ instructions from the wiki which restored HDMI and can see the UP logo upon restart but it immediately dumps me to a screen asking for a password. I have no way to press enter to get past that and cannot use F7 (or any key) during boot to bypass it. All the units were ordered without Bluetooth. If there is an alternative I’m overlooking, I’ll gladly follow instructions you provide. If not, should I proceed with the RMA, referencing this thread?

Sign In or Register to comment.