[SOLVED/ANSWERED]Does the UP Board UEFI BIOS version UPC1DM15 - have 32-bit BIOS?

Zach HershbergerZach Hershberger New Member Posts: 5
edited March 2020 in UP board BIOS

I am having trouble because I am running a Windows 10 32-bit OS and I just received new UP boards that have a 64-bit BIOS. I am currently unable to load my image or change the BIOS to 32-bit.

The problem is the new boards came with UPC1DM15 which from what I can tell is only 64-bit. I tried to downgrade to the old 32-bit BIOS (UPC1BM0X) I was flashing my systems (which is working on my original systems).

Whenever I try to run the go_64_32.nsh I get the following error: "4 - Error: ROM file ROMID is not compatible with existing BIOS ROMID." Which is most likely since I am attempting to downgrade the BIOS.

Anyone have a 32-Bit UPC1DM15 BIOS?

Comments

  • EmbeddedSchreckEmbeddedSchreck New Member Posts: 2

    Hi, did you found any 32 bit bios for the UP board until now. I searched for it but nothing found. It would be great if you would share it. Thanks a lot.
    Best Regards

  • DCleriDCleri Administrator, AAEON Posts: 1,162 admin

    32bit BIOS was only supported with the first revision of the BIOS, but it is not supported anymore

  • EmbeddedSchreckEmbeddedSchreck New Member Posts: 2

    Hi thank you for reply. But I don't understand your answer correctly....
    => I would need this old version?
    I have a SOIC onboard flash device. So it would be possible for me to flash the BIN to the UP board.

    My general Problem: I have a 1GB up board. I tried to get windows running on it. But Win10 - 64 bit can not be installed, because not enough memory (create Ramdisk failed during installation). So I want to try Win 10 - 32 Bit, because 1GB should be enough for the 32 bit version. But this 32bit installation does not boot out of 64Bit uefi...

    Best Regards

  • DCleriDCleri Administrator, AAEON Posts: 1,162 admin

    Hi @EmbeddedSchreck

    Unfortunately we cannot support 32bit OS and BIOS so the only way would be to install Windows IoT Core image or Linux.

  • karlhm76karlhm76 New Member Posts: 17

    You will need to be very careful .

    There is an option to bypass ROMID check by editing the .nsh file.
    I did that last time about 12 months ago, and it worked fine, but just now I have done it and my UP lo longer boots, or does anything.

    It is very unfortunate because this hardware is important for a project I have developed which requires 32bit OS.
    This UP platform does not have the same stability as other Aaeon products that we currently use for our systems.

  • DCleriDCleri Administrator, AAEON Posts: 1,162 admin

    Hi @karlhm76

    Thanks for your feedback but I can assure you that the UP platform has the same stability of the other AAEON products.

    You are simply using an untested and unsupported feature to enable 32bit OS, which also Intel does not support officially on new platforms. I think you can expect instability if you are using the product in a way that is not supposed to work.

  • karlhm76karlhm76 New Member Posts: 17
    edited November 2020

    Hi @DCleri , I meant stability as in hardware revision stability. This system is constantly changing and is not a good choice for commercial projects.

    The system I have developed using the UP board is very stable. When I purchased 2 additional systems to create additional prototypes for industry accreditation, I ran into lots of problems due to changes to these hardware systems that have occurred.

Sign In or Register to comment.