/etc/network/interface does not work

SilSil New Member Posts: 29 ✭✭

Dear all,
I am working with AP2 using Ubilinux.
I tried to configure the network using the file /etc/network/interface but it does not work. The network settings can be applied only by using the graphical network manager accessible by the menu. If you set your properties from the file they are ignored..
The only solution I found to work with the file /etc/network/interface is to remove the ConnMan e create my own file /etc/resolv.conf with the name of my nameservers.
Is there any other more elegant solution?
Thanks

Eng. Silvano Bertoldo, PhD

Comments

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 327 admin

    Hi @Sil,

    Could please share what do you want to get and how did you do it?

  • SilSil New Member Posts: 29 ✭✭

    Dear all,

    as I wrote, I am working with AP2 board using "Ubilinux".
    I tried to configure the network using the standard file /etc/network/interface but it does not work.

    I wanted my network settings set up only with the file /etc/network/interface because I have some scripts and applications changing the network settings.

    Unfortunately it seems that you can change the network setting using only the graphical interface, which is based on the daemon "ConnMan" (https://wiki.ubuntu-it.org/ConnMan). I actually do not know where the network settings set with this graphical tool are stored, but, it seems that if you use the graphical tool the file /etc/network/interface it totally ignored.

    The only solution I found to be useful was to remove the daemon "ConnMan":
    sudo apt remove connman

    After that I noticed that the file /etc/resolv.conf (https://en.wikipedia.org/wiki/Resolv.conf) was missing, so I manually created it by adding my DNS.

    In this way you cannot set netwotk properties using the graphical interface but you can modify everything using the standard file /etc/network/interface which is not ignored anymore.

    I do not know if there is any other solution more elegant, but this solution work well for me and it does not have any problem.
    For any suggestion and other solution write me.

    Silvano

    Eng. Silvano Bertoldo, PhD

Sign In or Register to comment.