Up2 Dead board... How to initiate RMA?

Options

I've been developing an idea for a couple of months now and suddenly, my board won't boot. I've tried holding the power button for a long period as well as using the power button pins on the board. The only odd thing that I noticed when trying to boot was the blue LED flickered and then the board simply won't power up.

I'm using the UP2 power supply and checked it to ensure that it is supplying power.

My board's part number is
UPS-APLP4-A10-0432

I purchased from Mouser on 11/22/18

Comments

  • Aling
    Aling Guest Posts: 561 admin
    Options

    It is possible that the factory BIOS setting is gone.Try to unplug the RTC battery for a minute, and plug it back, and see how it works.
    If it is still not possible to resolved, you can claim a RMA.

    You can claim RMA from Mouser. We offer 2 years warranty.

  • Sunken
    Sunken New Member Posts: 15
    Options

    I did try this and I also tested the battery to ensure that it has voltage. I also contacted Mouser, who directed me to contact AAEON. The RMA form cannot be found on the web site! http://us.aaeon.com/rma/rma01.asp?t=1
    I've also used the contact form without a response from AAEON......

    Please advise how to proceed.

Privacy Policy