Up Board + Realsense r200 + Ubuntu 18.04.2

ipeerbhaiipeerbhai New Member Posts: 4

I picked up an intel robotics kit dirt cheap, and am slowly spending a ton of time getting all the pieces up and running. I wanted librealsense, opencv4, and the 40-pin header all working. I want to putz around with depth, lidar, and neural networks... Oh, and watch netflix/sling... maybe run a 3d printer off it, too...

For anyone who is going to get one of these kits, and wants to get the whole shebang back up and as close to modern as possible, here's what I had to do.

  1. Ubuntu 18.04.2 UP instructions worked perfectly! Yay! I was able to blink leds via the file system echo > ... calls.
  2. librealsense v1.12.1 is the last version to support the r200. It doesn't compile any longer. I had to #include in archive.h, types.h in the librealsense source.
    2a. I could get the examples to compile, but getting them working with the freeglut library ended up killing video playback in chrome/firefox. So, I decided to live without some samples...
  3. I used these instructions for opencv 4: https://www.pyimagesearch.com/2018/08/15/how-to-install-opencv-4-on-ubuntu/ -- this mostly worked, but the final build directory location is incorrect. It's in /usr/local/lib/python...
  4. I followed these instructions for netflix: https://linuxconfig.org/watch-netflix-on-ubuntu-18-04-bionic-beaver-linux -- it worked.
  5. I followed these instructions for sling: https://linuxconfig.org/watch-sling-tv-with-firefox-on-linux -- it worked, with a warning. Warning -- get chrome first, then do this. Firefox will detect as Windows Chrome after the useragent hack, and downloading chrome becomes difficult.

I'm still hacking on getting all items to work, If I can get it all to work, I'll reply to this thread with any changes. Hopefully, anyone else who wants all this to work on an Up board will find this useful... So far, I've burned through about 50% of the 32gb eMMC, just installing libs/compiling...

I might go all the way and try to get ROS working as well, anyone get Melodic Morenia up and running on an UP board + realsense + garmin lidar lite in ubuntu 18.04 Desktop?

Comments

  • ipeerbhaiipeerbhai New Member Posts: 4

    Ok, I got librealsense built, and the python wrappers working. I had to modify the pyrealsense external library loader to include a path "/usr/local/lib/" to look for librealsense.so... So, short story -- you'll need to modify some source files to fix the various breaks -- but it's all straightforward. Use "pip install pyrealsense" after you "sudo make install" librealsense, then modify the site package's extlibs.py paths. I use virtualenv, so for me, it's in ~./virtualenvs/cv/lib/python3.6/site-packages/pyrealsense/extlibs.py. The test "hello world" example for pyrealsense will then work, and you can get color matrices from the camera.

    From here, the rest should be standard ubuntu 18.04 stuff. All up board and realsense 1.12.1 stuff is now installed.

  • ipeerbhaiipeerbhai New Member Posts: 4

    Also -- the #include in step 2 is the STD import for functional, which I can't write here as the editor thinks that's html...

  • savardosavardo New Member Posts: 1

    Hey! I bought the same intel robotic kit not so long ago. Just tought I'd let you know that I'll try following your steps for intel realsense r200 and python since I couldn't get pyrealsense installed on neither ubuntu or windows 10.

    The camera works with the realsense SDK 2016 R2 on windows 10 tho.

    I've tried some step-by-step installation guide for Ubuntu 16.04 without success, so i completely reinstalled it and I'll start from scratch.

    Which python IDE do you use on Ubuntu? I tried Pycharm since I use it on windows but I didn't really liked the linux version.

    I Hope I'll be able to install ubuntu 18, the first try didn't work.


    I'll keep in touch!

  • DCleriDCleri Administrator, AAEON Posts: 759 admin
Sign In or Register to comment.