Stiil no luck with Kodi or youtube in browsers

Danish ShaikhDanish Shaikh New Member Posts: 20
edited July 2016 in UP Board Linux
Ok, I have now done countless fresh installs of Ubilinux 3.0 (4.4.0-ubi3-amd64), trying to get kodi or youtube in a browser to run but no luck.

I have a wired network connection, so no WiFi dongle issues should cause any problems.

Every time I do a fresh install, and then
sudo apt-get update 
sudo apt-get upgrade 
So far so good....

Then I do
sudo apt-get install kodi
sudo apt-get install firefox-esr

So far so good....

Then I do a reboot, and when I'm logged back in, every time I try to play a youtube video in either Chromium or Firefox the system crashes with a X screen of death, where X is a random colour. This also happens when I try to run kodi.

What is going on :(:angry: ????? I have spent money on 2 wifi dongles and on a long ethernet cable (just so I could try the wired connection) and still I cannot seem to be able to do what I bought this board for - running a media center. I have a feeling there is something with the graphics libraries here....

Please advise, as I am all out of ideas here....

A very frustrated Danny

Comments

  • Javier ArteagaJavier Arteaga Emutex Posts: 163 mod
    edited July 2016
    Hi danishbizkit,
    I have a 5V, 6A supply, so there shouldn't be any power issues.
    Correct, a DC supply rated 5V/6A should be more than enough. Still, from the symptoms you describe, I think it would be a good idea to try a different power supply (rated at least 5V/3A). Reasons detailed below.

    I cannot use my keyboard (tried to Ctrl-Alt-Del my way out to reboot but nothing happens) or mouse. So it seems like there is power loss to all the peripherals, when I try to run something that is intensive for the graphics hardware.
    On its own, this doesn't necessarily mean loss of mouse/keyboard if you have lost your display. Ctrl-Alt-Del doesn't reboot on the default ubilinux desktop, but brings up the task manager instead. However, Ctrl-Alt-F1 (to switch to a virtual terminal) followed by Ctrl-Alt-Del *should* reboot if the board was still responsive...

    I can boot into the system, run most programs. When I try to play a youtube video in Chromium or Firefox, or try to start kodi, the board freezes with a x screen of death, where x is a random colour. When this happens, the blue power led (I assume it is a power led) turns off, as well as the network activity leds on the ethernet port.
    ...which it doesn't appear to be. Power/network LEDs turning off seem to suggest an unstable power supply. As for the solid color in the display, we have experienced that exact symptom along with a CPU hang when using power supplies that can't deliver enough current.

    I left the board in this state overnight, and I noticed that the board was still warm....meaning that the CPU was still running and most likely the OS was too.
    CPU still on, sure. Probably not actually running the OS though, from our experience.

    Thanks for your detailed report!
  • Danish ShaikhDanish Shaikh New Member Posts: 20
    You were right, it was indeed my power supply that was not powerful enough. Now I am using a 5V/4A guaranteed PSU, and it is going better. However, I did notice another potential issue...I can run kodi and play youtube videos in both kodi as well as the browser. But this is only possible when I use an unpowered HDMI to VGA cable to connect the UP to a VGA port on my monitor. If I use a direct HDMI cable, starting kodi or playing youtube videos results in a black screen of death but the other peripherals do not seem to power down as before.

    Is the 4A of current still not enough to drive the HDMI display controller properly? To test that, I have ordered a different 5A/4A PSU to double check 4A is definitely not enough, as well as a 5V/8A PSU as a back up.

    Will post an update when I have tested the two PSUs....
  • [Deleted User][Deleted User] Posts: 0
    Many cheap 5V chargers/power supplies are marketed with really inflated numbers . Especially 'multiport phone chargers' might have some issues. If you have problems choosing the right, I recommend Meanwell. A good 5V/4A supply can even temporarily provide 5V/5A.
Sign In or Register to comment.