Yocto Pyro 2.3 Boot from USB Device fails

Shazter New Member Posts: 9

Hello, based on the instruction (https://github.com/emutex/meta-up-board/blob/pyro/README.md) I was able to build my first Yocto image. I prepared the USB Stick with the image and plugged into my UP-Board. I selected Boot from the Boot menu and then following error message appear "Error loading \vmlinuz: Unsupported". I tried Install too, but same error message.

  1. What does this means?
  2. How to fix?

Build HOST PC OS: Virtual maschine with Ubuntu

UP-Board has currently Windows 10 64Bit installed. I would like to override this later.

BIOS Information

Core Version: 5.011
Project Version: UPC1D 0.64 x64
Build Date and Time: 08-30/2017 11:34:57



  • Shazter
    Shazter New Member Posts: 9

    To build the Live USB Stick I used a bit different image naming:

    dd if=upboard-image-sato-up-board.hddimg of=/dev/sdb1
    eject /dev/sdb1

  • Shazter
    Shazter New Member Posts: 9

    I updated to new BIOS version, then I used Etcher to write the upboard-image-sato-up-board.iso file (file was in the same folder as upboard-image-sato-up-board.hddimg), because I destroyed one usb stick with dd . I thought /dev/sdb1 is my usb stick, because fdisk -l showed /dev/sdb1. Etcher showed me /dev/sdb with a new stick.

    I was able to select "Boot" Option and I saw some boot sequence and short a Picture with Yocto Project, afterwards the screen keeps like in the shown picture.

Privacy Policy