[SOLVED] Avoid GNU GRUB menu at start up

MatAffMatAff New Member Posts: 18 ✭✭
edited December 2018 in UP Board Linux

Is there a way to avoid the GNU GRUB menu at start up? I'm using the UP board without any peripherals (keyboard, monitor), and am connecting through SSH. However currently I have to select ubilinux GNU/Linux from a menu before the board completes booting up. This means I still have to connect a keyboard, which I'm trying to avoid.

Other options in the same menu are:

  • Advanced options for unilinux GNU/Linux
  • System setup

The system setup takes me to the BIOS(?). I've had a look at the settings there, but haven't found the solution.

Tagged:

Comments

  • MatAffMatAff New Member Posts: 18 ✭✭

    I resolved this by changing the file /etc/default/grub

    sudo gedit /etc/default/grub
    

    In this file I changed grub time out from 5 to 0

    GRUB_TIMEOUT=0
    

    After closing the file make sure to update using:

    sudo update-grub
    
Sign In or Register to comment.