no more boot black screen

My Up2 no more boot, the screen remain black, there's just the blue light ant the blinking ethernet connector.
I tried many time to boot, just one time I got the sceen with AAeon picture and one time the grub menu but after the screen became black.
I tried to boot on bootable USB drive with ubilinux with no result (but I didn't test my usb drive before).
Is there a way to recover my data on the computer ?

Tagged:

Comments

  • DCleri
    DCleri Administrator, AAEON Posts: 1,189 admin

    if you can see the BIOS logo and grub, then you should try to boot via USB a live image of Ubuntu for example.

    Otherwise, try to unplug everything and also remove the RTC battery for a couple of minutes.
    Then re-plug again the RTC battery, then try again to use the board and check if you can boot up the system.

  • mibre
    mibre New Member Posts: 2

    Thanks for your advice but I didn't succeed . After many try to boot on ubuntu 18.04.1 usb drive, I only succeed one time to get Ubuntu screen . It seems to work but when I tried to recover my data on an external hard disk I got the message "the computer will shutdown in 50s" !