EFI: Cannot find required map name

kevinkkevink New Member Posts: 7

I am currently building a PCB to attach the upboard and during an initial test I accidentally removed the CMOS battery. I understand this resets the clock as well as the BIOS settings. I previously had ubuntu installed on it and would like to be able to recover some files on it.

Are there any bios settings that I am forgetting to adjust or is the only way back a fresh install?

Thanks.

Comments

  • eduncan911eduncan911 Administrator, Moderator Posts: 157 admin

    @kevink said:
    I am currently building a PCB to attach the upboard and during an initial test I accidentally removed the CMOS battery. I understand this resets the clock as well as the BIOS settings. I previously had ubuntu installed on it and would like to be able to recover some files on it.

    Are there any bios settings that I am forgetting to adjust or is the only way back a fresh install?

    Thanks.

    You should be able to boot the device again. Odd though, as the BIOS defaults to booting UEFI on the internal eMMC atorage and should just work with a bios reset (pulling battery).

    Start by going into the BIOS and looking for Boot settings. It might say Hard Drive, and make sure it is selected as a boot option.

    Eric Duncan - UP Evangelist - My thoughts are of my own free will

    Answered? Please remember to mark the posted answered to highlight it for future visitors!

  • kevinkkevink New Member Posts: 7

    In the bios setup utility I am not seeing anything about the hard drive. Only Quiet Boot and OS Image ID. I've tried manually resetting to the defaults but still boots to the EFI screen. I leave the EFI by typing exit and I am taken to the Aptio setup utility where I am able to change the settings.

    Any idea where else I might find the hard drive setting?

  • eduncan911eduncan911 Administrator, Moderator Posts: 157 admin
    edited October 2018

    @kevink said:
    In the bios setup utility I am not seeing anything about the hard drive. Only Quiet Boot and OS Image ID. I've tried manually resetting to the defaults but still boots to the EFI screen. I leave the EFI by typing exit and I am taken to the Aptio setup utility where I am able to change the settings.

    Any idea where else I might find the hard drive setting?

    Yeah, the Hard Drive thing must have been from a different device. :smile: Sorry about that.

    I just flashed my UP Board to the latest BIOS image from 2018.

    If I enter the BIOS and go to:

    BOOT  -> Boot Option #
    

    I can pick what items I want to good first.

    It looks like the EFI Title of the installed OS is shown here. So, if you have Ubuntu install, you will need to make the first "Boot Option #1" say "Ubuntu" or some variant.

    I would also disable any other Boot Option #2, #3, etc as well to remove any confusion.

    If you have more than one Ubuntu listed, then perhaps you tried to install Ubuntu multiple times until one finally stuck. In that case, I would pick different Ubuntu Boot Options until one worked. If that is the case, write back and I can help you clean up your boot configuration within the OS and system once you are back into the system.

    Good luck!

    Eric Duncan - UP Evangelist - My thoughts are of my own free will

    Answered? Please remember to mark the posted answered to highlight it for future visitors!

  • kevinkkevink New Member Posts: 7

    That's what I originally tried to check; it doesn't list any boot options.
    It says:
    " Boot Configuration
    Quiet Boot [Enabled]
    OS IMAGE ID [Windows 8.1] (other option is Android)

    Boot Option Priorities
    "
    Then it lists no boot options.

    Is it safe to assume any previous install is lost?

Sign In or Register to comment.