Windows 10 AAEON Framework Driver Signature

JD86JD86 New Member Posts: 5

When installing the AAEON Framework Driver in Windows 10 LTSB, I get the following error message in the device-manager:
Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52).

I suspect this issue arrises due to the driver not being signed correctly.

Are there any plans to release a properly signed Driver in the Future?
If not, is there any way to use the AAEON Framework without losing the ability to activate TMP?

greetings,
-JD

Comments

  • ApeiChenApeiChen New Member, Moderator, AAEON Posts: 23 admin
    edited September 2018

    Hi JD,

    Could you provide the Win10 detail version info to me?
    Thanks.

    Apei

  • JD86JD86 New Member Posts: 5
    edited September 2018

    Hello Apei,

    the detailed version info is: Windows 10 Enterprise 2016 LTSB Version 10,0,14393 Build 14393,

    The specific problem I have is that whenever I try to activate SecureBoot in the BIOS, the AAEON Framework driver stops working altogether, and the aforementioned error is shown in the device mananger.

    Thanks,
    JD86

  • ApeiChenApeiChen New Member, Moderator, AAEON Posts: 23 admin

    Hi @JD86 ,

    Could you also kindly provide your BIOS version and Aaeon Framework version to us?
    Thank you.

    Apei.

  • JD86JD86 New Member Posts: 5

    Hello Apei,

    The BIOS version I'm using is the following: "American Megatrends Inc. WG116A10 08.06.2018".

    I'm also using Driver Version 0.0.0.0 , from 14.08.2017.

    Heres a screenshot of the error

    Thanks,
    JD

  • ApeiChenApeiChen New Member, Moderator, AAEON Posts: 23 admin

    Hi @JD86 ,

    Could you help to update your BIOS to the latest one on UP community?
    I think the yellow bang will be gone.

    Many Thanks.
    Apei.

  • jwilfongjwilfong New Member Posts: 2

    This worked for me...

    Disable Windows 10 enforcement of driver signatures, then follow the instructions in the included doc file.

    To disable:
    1. Click the windows Start menu and select Settings
    2. Click Update and Security
    3. Click on Recovery
    4. Click Restart now under Advanced Startup
    5. Click Troubleshoot
    6. Click Advanced options
    7. Click Startup Settings (if this does not appear, there should be a link for more options. It will then appear.
    8. Click Restart (Restarting will bring up another screen with various startup options)
    9. On the Startup Settings screen, press 7 or F7 to disable driver signature enforcement.

    Now, follow the instructions for installation and the responses shown in the document will match what you see. Once you install the driver and restart the computer again the driver signature enforcement will b re-enabled.

Sign In or Register to comment.