How to setup Zaphode mode in Ubuntu

Black_G3Black_G3 New Member Posts: 3

Hello,

We are having issue to setup Zaphod mode in Ubuntu.
UP Square board with BIOS 2.1
Ubuntu 16.04 and 18.04 with built-in X server and Intel driver (no change)

/etc/xorg.conf
ection "ServerLayout"
Identifier "Layout0"
Screen "Screen0" 0 0
Screen "Screen1" RightOf "Screen0"
EndSection

Section "Device"
Identifier "Device0"
Driver "intel"
BusID "0:2:0"
Option "ZaphodHeads" "DP1"
Option "AccelMethod" "sna"
Screen 0
EndSection

Section "Device"
Identifier "Device1"
Driver "intel"
BusID "0:2:0"
Option "ZaphodHeads" "HDMI1"
Option "AccelMethod" "sna"
Screen 1
EndSection

Section "Monitor"
Identifier "DP Monitor"
Option "PreferredMode" "1920x1080"
EndSection

Section "Monitor"
Identifier "HDMI Monitor"
Option "PreferredMode" "1920x1080"
EndSection

Section "Screen"
Identifier "Screen0"
Monitor "DP Monitor"
DefaultDepth 24
Device "Device0"
EndSection

Section "Screen"
Identifier "Screen1"
Monitor "HDMI Monitor"
DefaultDepth 24
Device "Device1"
EndSection

After boot into Ubuntu, only DP has screen. HDMI is blank. Tried DISPLAY=:0.1 firefox& saw firefox on HDMI but it is not responding to any mouse click. We also see rendering issue and screen flickering.

Can some one help us setting up Zaphod mode? Thanks

Black G3

Comments

Sign In or Register to comment.