USB device mode only works in 2.0

zhangyuf0224zhangyuf0224 Posts: 2New Member

Hello,

I am trying to make the up board a mass storage device and have it working partially. The problem I have now is that the device only works in 2.0 mode (480Mbps) instead of 3.0 mode (5.0Gbps). I tried Ubuntu server 18.04, 16.04 and also tried building my own kernel version 4.9.45.

The USB port works as USB 3.0 if an OTG adapter is connected and working as a host when connected to a USB 3.0 card reader (the reader is shown under 5000M root hub with lsusb -t), but I can never get it working as a device as 3.0. I am using a Type-A to 3.0 micro Type-B cable, confirmed working on other 3.0 devices.

Any suggestion would be very much appreciated. Thanks in advance.

Comments

  • ccaldeccalde Posts: 199New Member, Emutex mod

    Hi @zhangyuf0224 ,

    Please check the hardware specs for UP board: https://wiki.up-community.org/Hardware_Specification

    As you can see, the only USB 3.0 is for OTG.
    It looks like that is the only one you could use as 3.0...

    Cheers!

  • zhangyuf0224zhangyuf0224 Posts: 2New Member

    Hi @ccalde

    Thanks for your reply. The link shows

    "Device mode is currently supported through a configuration option from the BIOS menu"

    and I am using Device mode. However it's running only at USB 2.0. USB 3.0 OTG port works in Device mode at 3.0 speed doesn't it?

    Thank you

  • ccaldeccalde Posts: 199New Member, Emutex mod

    Hi @zhangyuf0224 ,

    Yes, the USB 3.0 OTG port works as device mode by default and the only one working at 3.0 as specifications said.

    Why do you say your OTG is running at USB 2.0?

    Thanks

  • toumoutoumou Posts: 8New Member

    Hi

    Same issue here

    Despite latest UEFI firmware, multiple kernel versions, USB cables... I am unable to get my board working in device mode at super speed.

  • toumoutoumou Posts: 8New Member

    For your information I updated my initial post here.

    Unless upboard people plan to fix the issue, forget this board for superspeed device mode.

  • ccaldeccalde Posts: 199New Member, Emutex mod

    Hi @toumou ,

    Thank you very much for the info.

    We will look into that issue deeper.

Sign In or Register to comment.