BIOS Update May 2018 - not working?

TilTil New Member Posts: 19

Hi,

I tried to update the BIOS of my UpBoard (4GB/64GB) today to UPC1DM11.
I downloaded the file, extracted its content to a FAT32 formatted USB stick (just as described in the wiki).
After double-checking that History.txt also showed "UP-CHT01" as target device for this update I gave it a try and ran GO.nsh, but only to be shown the following:

What did I do wrong? Why didn't it work?

PS:
You really should update the wiki page
1. "Launch EFI Shell from filesystem device" claimed "No device found", so in order to get to the USB stick I had to rearrange the boot order.
2. Since there was no "go_60.nsh" included in the file I gave the "GO.nsh" file a try.

Comments

  • TilTil New Member Posts: 19
    edited May 2018

    Am I the only one having this problem?
    My suspicion is that the update itself might be faulty, but having only one board, I cannot verify this.

    Since in total only about 16 people downloaded it so far (the counter says 20 now, but I account for four of these), it doesn't seem to be that widely spread (yet).

  • T1000T1000 New Member Posts: 5

    Got the same error as you but fixed it.

    Just received my UP Board just less than a week ago and only had a couple of hours over this weekend to play with it. Didn't have much luck then as, when I stuck in the USB with the BIOS update, UB just kept on rebooting as soon as it got into EFI shell.

    Tried again last night. Removed all files from the USB, stuck it back in and got to EFI shell without rebooting. Figured it may have been the EFI folder screwing things up so copied just the UPC1DM11 folder to the USB. After booting back up, tried to run GO.nsh in the UPC1DM11 folder and got the same error message as you.

    Looked at Wiki help page again and found one thing different. We were both on blk1: when running GO.nsh. Tried going to fs1: as described in the Wiki help page and the update installed without any issues. Took about 5 ~ 10 minutes.

  • TilTil New Member Posts: 19
    edited May 2018

    You're right, fs1: worked! :o

    I only saw blk1 in the list, so I used this, thinking it was just what I saw in the picture in the wiki (there was more text flying by, but I couldn't read it). Apparently the "fs1" line had scrolled off screen in that process...

    Thanks a lot!

  • Josef RogovskyJosef Rogovsky New Member Posts: 18
    edited June 2018

    @Til, Thanks very much for the tip on changing the boot order to fix the "no device found" error.

  • biashabiasha New Member Posts: 2
    edited June 7

    @T1000 said:

    UB just kept on rebooting as soon as it got into EFI shell.

    I had the same issue and really want some comment from developers.

    The reason is that UPC1DM17\EFI\BOOT\startup.nsh does

    cd UPC1BM0P         <=== whut? 05/05/2016 version? no such dir
    go_nsh              <=== fails obviously. no such file
    reset               <=== infinite reboot loop
    

    is it just a typo?
    Is it some kind of dirty workaround code?
    what sould it actually run?

    P.S.
    "echo -off" helps a lot, lol... like "let's hide everything for a good reason"

Sign In or Register to comment.