eDP for Up Core 4 GB

gianlucagianluca Posts: 8New Member

Hello,
we are trying to use the UpCore with an eDP display from BOE (the datasheet in attachment).
After the correctBIOS setup (Panel Support Enabled, interface eDP) the TFT Display is recognized (Win 10 Pro 64 bits can see it), Backlight is on, but nothing appears in the screen. Connections are correct. We realized them through a small adapter PCB: one side has the same CN6 connector of UpCore, while the other side has a simple 30 contacts FPC connector for the display. Traces on the PCB are calibrated to have the same lengths (LANE 0+ and LANE 0- have the same length L0, AUX+ and AUX- have the same lengths L1. L0 and L1 are slightly different). Total length of the connection is around 12cm.
All the drivers are installed (plus a one from Intel Graphics).
Can you help to understand where we are wrong?
Is there any known issue about eDP on UpCore?

Thank you very much in advance
GianLuca

Answers

  • ccaldeccalde Posts: 90New Member, Emutex mod

    Hi @gianluca ,

    Did you see anything during the boot of the UP board?

    It could be an issue with the resolutions used for UP...Could you tell me which resolution it uses?

    Cheers!

  • gianlucagianluca Posts: 8New Member

    Hello,
    the BOE TFT Panel is 1280 x 800 pixel.
    When Windows 10 recognizes this TFT, it sets automatically the resolution to be 1280 x 800.
    Backlight is always ON but nothing appears....
    I'm working with the eDP panel and an HDMI monitor to see what's happening. eDP one is recognized as 1, HDMI one is recognized as 2.
    Screen mode is clone (1+2)
    Any other ideas? :-)
    Thank you very much!
    GianLuca

  • ApeiChenApeiChen Posts: 5New Member

    Hi @gianluca ,

    I think you should review the DSI connector mapping, compare the mapping between UP core and your BOE eDP panel.
    Attachment is Manual of UP core, you can find the DSI connector mapping (CN31) in page.10 .
    The mapping should be same as each other, otherwise, panel won't display normally.

    ftp://data.aaeon.com.tw/DOWNLOAD/MANUAL/UP-CHCR1 manual 1st Ed.pdf

    or you can find this Manual on aaeon website by using keyword "UP Core".
    Thank you.

    Apei.

  • gianlucagianluca Posts: 8New Member

    Hi Apei,
    thank you for your suggestion but I already did.
    My Windows 10 is the latest version (build 1803) obtained through the Microsoft Media Creator.
    Is it possible that there are some issues with this release?

    Thank you

    GianLuca

  • gianlucagianluca Posts: 8New Member

    does anyone has the same problems?
    Thanks
    GL

  • ApeiChenApeiChen Posts: 5New Member

    Hi @gianluca ,

    I think this problem don't relate to your system is Windows 10 or else if you cannot see anything from boot.
    Have you compared the signal between the "Panel Adaptor" and "DSI connector mapping (CN31)"?
    I cannot find the mapping of your BOE panel adaptor in your attach file, so I don't know if the signals are match or not.
    Maybe you can ask BOE for adaptor info to check signals.
    If signals matched, maybe you should focus on panel, cables and adaptor.
    Also, take a picture to show your hardware system settings is better.
    Thank you.

    Apei.

  • gianlucagianluca Posts: 8New Member

    Hello Apei,
    I have 5 UpCores here now.
    Just installed the same Win 10 in each one, and then I've installed the drivers (downloaded here in the web site). Used the same PCB and same cables to connect the UpCore with the BOE
    2 are working, 3 are not working...... Then, I have a last driver to install (UART): it doesn't work due to some language(???) problem.
    I tried to install the Language Pack from Microsoft and... the eDP stopped working!!!

    Consider that I may have some customers interested in such technologies but (hope you understand) actually I don't feel so comfortable to propose your ones.

    Please, go in deep in this issue
    Thank you very much
    GianLuca

  • ApeiChenApeiChen Posts: 5New Member

    Hi @gianluca ,

    If it is single case for your up core, could you kindly contact the contact person for helps.
    Maybe send back the product for engineers to debug or local FAE help to clarify problems could be more helpful.
    That can get more information than just discuss it on web only and give you more and more helps directly.
    Thank you very much.

    Apei.

  • gianlucagianluca Posts: 8New Member

    Hello Apei,
    I don't know who is the contact person :-)
    It seems to me that is some issue with Windows 10 (unstable driver?).

    Always waiting for suggestions if someone has...
    Thank you all
    GianLuca

  • ApeiChenApeiChen Posts: 5New Member

    Hi @gianluca ,

    Maybe you can reference this web as below.

    https://up-shop.org/content/5-cancellation-and-return-policy

    Thank you very much.

    Apei.

  • gianlucagianluca Posts: 8New Member

    Hi Apei,
    I don't want to return the Up Cores... I want to make them works
    Thank you
    GianLuca

  • ccaldeccalde Posts: 90New Member, Emutex mod

    Hi @gianluca ,

    Which kernel version are you using for your UP core?

    Cheers!

  • gianlucagianluca Posts: 8New Member

    Hi Ccalde. First time the UCR1BM10, then the UCR1BM13 that I found on the downloads page
    Thank you!

Sign In or Register to comment.