Ubuntu 18.04 support for the Up Board

2»

Comments

  • ccaldeccalde New Member Posts: 348 admin

    Hi @ddd ,

    The kernel 4.15 is working properly for Ubuntu 18.04.
    You could remove the generic kernel for Ubuntu 18 and install our kernel without any problem. Also, if you want, you can install our kernel directly and then remove the generic one manually.

    About the upboard-extras packages, It was updated for Ubuntu 18. Please try again after add the UP repository:
    https://wiki.up-community.org/Ubuntu#Enable_the_HAT_functionality_from_userspace_2

  • gerfengerfen New Member Posts: 20

    I'm currently trying to set up a UP2 board with Ubuntu 18.04 following the instruction here https://wiki.up-community.org/Ubuntu#Ubuntu_18.04_installation_and_configuration and I am getting the following error:

    [email protected]:~$ sudo apt-get install linux-image-generic-hwe-18.04-upboard
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    You might want to run 'apt --fix-broken install' to correct these.
    The following packages have unmet dependencies:
     linux-image-4.15.0-46-generic : Depends: linux-modules-4.15.0-46-generic but it is not going to be installed
     linux-image-generic-hwe-18.04-upboard : Depends: linux-image-unsigned-4.15.0-37-generic but it is not going to be installed
                                             Depends: linux-modules-extra-4.15.0-37-generic but it is not going to be installed
                                             Recommends: thermald but it is not going to be installed
    E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    

    I have attached the full logs while I was flowing along with the instructions. Do the instructions need to be updated? What do I need to do to complete the installation? Should I instead use Ubuntu 16.04?

    Thanks!

    --Michael

  • ccaldeccalde New Member Posts: 348 admin

    Hi @gerfen ,

    The Ubuntu18 + kernel 4.15 is working properly from my side.

    What about the apt --fix-broken install command? did you try to solve the install issue?

  • jayb967jayb967 New Member Posts: 3
    edited March 2019

    Any update? I have also not been able to install kernel 4.15 version on 18.04 ubuntu without bricking the system..
    apt --fix-broken install command reinstalls generic kernel over again

  • mattcurfmattcurf New Member Posts: 1

    @ccalde, I am also not able to install kernel 4.15 on 18.04: the package does not appear to have anything other than a copyright file, and there are no other dependencies. Broken package?

    $ dpkg-query -L linux-image-generic-hwe-18.04-upboard
    /.
    /usr
    /usr/share
    /usr/share/doc
    /usr/share/doc/linux-image-generic-hwe-18.04-upboard
    /usr/share/doc/linux-image-generic-hwe-18.04-upboard/changelog.gz
    /usr/share/doc/linux-image-generic-hwe-18.04-upboard/copyright
    $ apt-cache depends  linux-image-generic-hwe-18.04-upboard
    linux-image-generic-hwe-18.04-upboard
      Depends: linux-image-unsigned-4.15.0-37-generic
      Depends: linux-modules-extra-4.15.0-37-generic
      Depends: linux-firmware
      Conflicts: linux-image-generic
      Recommends: thermald
      Replaces: linux-image-generic
        linux-image-generic-hwe-18.04-upboard
    
  • ccaldeccalde New Member Posts: 348 admin

    Hi @mattcurf ,

    Could you send me all the outputs for each step provided in the UP Wiki as the official instructions for Ubuntu 18?
    https://wiki.up-community.org/Ubuntu#Install_Ubuntu_kernel_4.15.0_for_UP_from_PPA_on_Ubuntu_18.04

  • JamesTCUrranJamesTCUrran New Member Posts: 2

    Hello All, I have just experienced the same problem trying to install kernel 4.15.0 on Ubuntu 18.04.
    I experienced the "apt --fix-broken install" problem, and found that the machine could not reboot.
    Perhaps it would be worth noting this on the Wiki to save people killing their installed systems.

  • ccaldeccalde New Member Posts: 348 admin

    Hi @JamesTCUrran ,

    I tried last day to install Ubuntu 18.04 and the official UP board kernel 4.15 following step by step ALL the instructions on an UP board.
    I didn't find any error or fail during the kernel installation...
    Could you tell me which BIOS version you have in your UP?
    Also, all the outputs for each step during UP board kernel installation?

  • drhalftonedrhalftone New Member Posts: 3
    edited March 2019

    It will take me a bit of time to gather this information. I can tell you that I'm running BIOS UP-APL01 R2.1 (UPA1AM21)(09/01/2017) and that the first error occurs while trying to remove the old kernel. Specifically, with about 8kbytes of packages not removed, the command line tells me that it can't or won't remove the currently running kernel. I ran the code exactly as listed on the webpage, using cut and paste to move commands from my browser to the command terminal. I ran the kernel removal line once. Saw the error. Did the sudo apt fix command. And then re-ran the kernel removing code again to the same error. As a matter of fact, I did not connect my system to WiFi during or after OS installation just so I could disable automatic updates. Only after I disabled automatic updates, did I connect my system to WAN over Wifi so I could run this kernel installation procedure.

  • drhalftonedrhalftone New Member Posts: 3

    Here is a transcript of my session trying to replace the kernel.

  • ccaldeccalde New Member Posts: 348 admin

    Hi @drhalftone ,

    First, we always recommend to update the BIOS. You have a R2.1 and the latest is R4.0 version:
    https://wiki.up-community.org/Bios_Update
    https://downloads.up-community.org/download/up-squared-uefi-bios-v4-0/

    Also, I can see during the remove generic kernel this mark:
    "Aborting removal of the running kernel"

    Did you abort the process when the installer ask to remove the generic kernel?

  • drhalftonedrhalftone New Member Posts: 3

    You are correct! I repeated the process, and realize now that when the splash screen came up asking me to confirm kernel removal, I read the panel as asking me to continue instead of abort. So by saying, "yes," I was actually aborting the procedure instead of continuing it. So I have successfully replaced the kernel following your instructions; however, I new problem has come up. Upon rebooting, I can no longer connect to my WiFi network. I should be connected over 802.1X, EAP-PEAP (MASCHAPv2). But since rebooting, Ubuntu fails to connect to the network. I tried running the instructions following reboot over a physical ethernet cable, but have had no luck getting WiFi to work.

    What can I do?

  • JamesTCUrranJamesTCUrran New Member Posts: 2

    Hi @ccalde,
    thanks for the note. I retried after updating to the latest BIOS version (4.0) and it went smoothly.
    My bad, I should have followed the instructions more closely.
    Thanks for the update.
    James

  • Trunganh1131Trunganh1131 New Member Posts: 9

    I also have the same question with you, and are looking for answers here

Sign In or Register to comment.