battery hat susv is not detected on one of two reboots

asilvaasilva New Member Posts: 13

Hi,
i'm facing an issue that after one of two reboots the battery hat susv is not detected.

Attach the system information when the device is present and not. I can't find any difference in the i2c definition...

anyone facing the same issue?

NOTE: i don't have the last firware from susv because it also reproduces this issue and introduces another one (reboot on power failure.. https://forum.up-community.org/discussion/2851/s-usv-ups-firmware-version-2-40-reboots-after-power-failure)

Comments

  • asilvaasilva New Member Posts: 13

    well.. just figure out the issue.. the i2c device changes after the reboot.
    I could detect the new i2c device by probing with i2cdetect -r DEVID, one of the times it was the id 5.

    [email protected]:~# i2cdetect -r 5
    WARNING! This program can confuse your I2C bus, cause data loss and worse!
    I will probe file /dev/i2c-5 using read byte commands.
    I will probe address range 0x03-0x77.
    Continue? [Y/n] y
    0 1 2 3 4 5 6 7 8 9 a b c d e f
    00: -- -- -- -- -- -- -- -- -- -- -- -- 0f
    10: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    20: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    30: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    40: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    50: -- -- -- -- -- -- -- -- -- -- -- -- -- -- -- --
    60: -- -- -- -- -- -- -- -- 68 -- -- -- -- -- -- --
    70: -- -- -- -- -- -- -- --

    The 0x0F indicates de s.usv hat.
    After that, in the configuration file /opt/susvd/susv.cfg, with version 2.40, set the parameter i2c device:

    [i2c]
    device="/dev/i2c-5"

    anyone knows how to prevent i2c device from change on reboot?

  • Douwe van NijnattenDouwe van Nijnatten New Member Posts: 5

    Hi,

    I am facing similar difficulties. Have you (or anybody else) gotten any closer to a solution?

  • rchauvinrchauvin New Member Posts: 13

    Hi,
    Same here, the i2c device changes after the reboot.
    I didn't find a solution yet..

  • rchauvinrchauvin New Member Posts: 13

    Hi,
    Here is the answer from S.USV support about the issue:
    "We can confirm that this a well-known problem within Ubilinux and is dedicated to the OS itself. A lot of users independently of the S.USV users already reported this problem to the manufacturer (Aaeon) but without any success up to now."

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 348 admin
    edited December 2018

    Hi all,

    Thanks for the information, we will take a look at that issue.

  • rchauvinrchauvin New Member Posts: 13

    @ccalde said:
    Hi all,

    Thanks for the information, we will take a look at that issue.

    Hi @ccalde,
    Have you had time to look at this issue?

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 348 admin

    Hi @rchauvin ,

    Unfortunately, not yet.

    Could confirm that issue is only for Ubilinux and not for UP board Ubuntu 16.04?
    https://wiki.up-community.org/Ubuntu

  • rchauvinrchauvin New Member Posts: 13

    Hi @ccalde,
    Initially I installed Ubuntu 16.04 on the UP squared board. But I had too many issue to get the S.USV working properly on Ubuntu. So I ended up by installing Ubilinux. It is working except for this reboot issue.

    According to Olmatic GmbH:
    "The only way to solve this issue in the meanwhile is to create a script, executed at boot time, which checks the correct i2c-bus and automatically changes the “susv.cfg” before starting the Daemon."
    I would prefer not to go for this workaround.

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 348 admin

    Hi @rchauvin ,

    Thanks for the update for Ubuntu.
    As soon as possible I get a battery hat here, I will check that issue.

Sign In or Register to comment.