[SOLVED] Mcp251x CAN driver errors.

MaryemAyadiMaryemAyadi New Member Posts: 4
edited July 2019 in UP Board Linux

I am trying to setup mcp251x on UP2. When I run dmesg | grep mcp , this is what I get:

 [ 3394.625374] device: 'spi1.0': device_add

 [ 3394.625384] bus: 'spi': add device spi1.0

 [ 3394.625460] PM: Adding info for spi:spi1.0

 [ 3394.625478] bus: 'spi': driver_probe_device: matched device spi1.0 with driver mcp251x

 [ 3394.625480] bus: 'spi': really_probe: probing driver mcp251x with device spi1.0

** [ 3394.625487] mcp251x spi1.0: no default pinctrl state**

 [ 3394.625494] devices_kset: Moving spi1.0 to end of list

 [ 3394.655161] mcp251x spi1.0: Cannot initialize MCP2515. Wrong wiring?

 [ 3394.662335] mcp251x spi1.0: Probe failed, err=19

 [ 3394.667521] mcp251x: probe of spi1.0 rejects match -19

What does the error "no default pinctrl state" refer to ?

Any help ??

Comments

  • justasonjustason New Member Posts: 1
    edited July 2019

    I hope, You have resolved your problem,.
    Anyway, check first your devicetree, that all pincontrol are declared and in correct state.
    For instance google "mcp2515 linux devicetree"

Sign In or Register to comment.