Windows 10 Drivers Not Installable

Robert SheltonRobert Shelton New Member Posts: 109

I have cycled again thru the download / install of the Windows 10 drivers file for Up Core. Still no success. This time I am attempting to install drivers from within the Update Drivers dialogue in Device Manager. Every "unknown device" that I attempt to update give me a "Windows encountered a problem installing the drivers for your device" error dialogue, further mentioning "AAEON DEV_22AB" and "The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering." Given that (as I've noted elsewhere on the Forum) item #2 for WiFi drivers is missing, I'm concluding that the Windows drivers file was not properly built or tested before the Up team posted it in Downloads.

At this point, I'm stuck using my Core with a USB 3 dongle so I can add WiFi and BT4 adapters. The built-in WiFi/BT does not work. Audio thru my HDMI monitor does not work - device not present according to Windows. And I have 5 "Unknown device" entries under Other Devices in my Device Manager.

This needs to be addressed ASAP. Core has been released for general availability via Up Shop, but we're still not able to use basic functionality that would make Core a functional, useful product.

Comments

  • mrjonandrewsmrjonandrews New Member Posts: 7

    @Robert Shelton - did you ever get a solution for this?

    I'm trying to use the Windows 10 drivers from the Up Core download section dated 20180131 but the setup fails on step1-chipset with a [String ID not found] error from the Intel x64 CherryTrail-T Driver Package installer.

    I've read on a few other posts to try either the Up2 drivers or the Up board drivers. Any help would be much appreciated!

  • mrjonandrewsmrjonandrews New Member Posts: 7

    I found out what my problem was :)

    Because my Up Core obviously had no wifi or internet connection, I was downloading the drivers onto my laptop and transferring them via a usb stick. Perfectly reasonable right?

    Only, it seems that my laptop mac was corrupting the files somehow because when I downloaded the same files using another PC and transferred them to the usb stick, they installed fine on my UP Core!

    Crazy huh. But I suspect there's more than a fair chance that somebody else is having this same problem so I thought I'd share.

    J

  • Samuel100Samuel100 New Member Posts: 3

    Same was the problem with my brother 2 weeks ago, any good reply that can give a solid case in point

    I help people get rid of their sick tired life and I love discovering passive sources of income that most people ignore:)

Sign In or Register to comment.