Realsense D415/ UP board USB connectivity issues

dvhardwaredvhardware Posts: 6New Member

I am using the UP board 4GB ram/ 32GB storage, part # RE-UP-CHT01-A12-0432.

Previously I used it with the Realsense R200, as part of the realsense developer kit, found here: https://click.intel.com/intelr-realsensetm-robotic-development-kit-2461.html

I have acquired some of the new Realsense cameras, the D415, and am trying to integrate it with the UP board and my computer vision software. I can't use the cable supplied with the D415, because it is USB type C to type A, and the type A ports on the UP board are USB 2.0, not 3.0 as the D415 requires.

I have also tried this cable:
https://www.amazon.com/gp/product/B012V56992/ref=oh_aui_detailpage_o07_s00?ie=UTF8&psc=1

I can get the UP board to recognize the D415 using this cable, but it is listed as a USB 2.0 device, even though it is plugged into the USB 3.0 Micro B port.

If anyone could please assist me on what could be the issue I would really appreciate it.

Thank you!

Tagged:

Comments

  • TooBarFooTooBarFoo Posts: 11New Member

    Just try a different cable, out of three I tried only one gave me the usb3.1 I needed. USB-C is a strange beast being a connector definition only and supporting or not supporting many different protocols. I think I had to avoid thunderbolt compatibility in order to get 3.1 function. So avoid cables marked as macbook. I would give this one https://www.amazon.com/Fasgear-Braided-Connector-Charging-Syncing/dp/B0779TNFDV a try, but again it was hit or miss for me and I am not in the US so my sources are no help.

Sign In or Register to comment.