Inability to edit (or most of the time even enter) BIOS setup

bedgearbedgear New Member Posts: 3

I love the board, and i already have Windows 10 installed and working quite well. I am, however, having issues with the BIOS it would seem.

Since I've gotten the board I have not been able to get into the BIOS setup without pulling the RTC battery and resetting everything. The few times I've been inclined to do that, I've been able to get into setup, but when i try to change anything, or even after a couple seconds the screen just freezes andI cant get any response. I have to reset the board (generally done with Ctrl+Alt+Del) and try again. When I try the second time, i dont even get to the BIOS setup screen. I get shown a page that says "Enter Password" in a little box, and nothing else. Here, there is once again no response. I cant type anything, pressing enter without pressing any other keys first doesnt get me anywhere, all I can do is reset the board. No matter how many times I try after that, no matter how long I leave it to sit, all i get from the second boot on in the password screen with no response. (The numlock light on the keyboard will occasionally respond to me pressing the numlock key. Other times it just doesn't come on at all, it just stays on no matter what i do until its reset.

I know its not an HDMI cable issue as I have now tried 4 different HDMI cables to try to get somewhere with this. I know its not an issue with my monitor because I use the monitor (on HDMI) for use on my primary machine daily and for long periods. Additionally, I have tried another monitor, and got the same result. I have also been able to flash the BIOS (had to boot into the USB drive using the windows boot manager, but it worked and I tried the BIOS setup method on a previous topic to flash the BIOS successfully) and that did not change anything.

Anyone have any ideas on what to do next?

Comments

  • Javier ArteagaJavier Arteaga Emutex Posts: 163 mod

    Hi @bedgear,

    It doesn't sound like a video output issue at all.

    • What does your input setup look like (e.g. are you using a USB keyboard?)
    • Do you have any other peripherals connected?
    • Which power supply are you using?
    • What version is the BIOS you flashed?

    Thanks!

  • bedgearbedgear New Member Posts: 3
    edited February 2018

    Thanks for getting back to me @Javier Arteaga.

    -My input setup is fairly simple. I have a USB keyboard plugged into the USB 3.0 port on the board. There is a USB mouse plugged into the keyboard, but I have tried it with and without the mouse attached to the keyboard.
    -Other than the keyboard and the occasional mouse, I have no other peripherals connected. (not that I have never had other things attached, just for troubleshooting I brought it down to the minimum.)
    -I am using the power supply that shipped with my UP Core. (5V 2.4A i think. American Plug.)
    -The version I flashed I think is called UP-CHT01 (at least thats what it says in the HISTORY file). I downloaded it from the downloads section yesterday. I used the 2GB/4GB version, as I have a 4GB board.

  • bedgearbedgear New Member Posts: 3

    Anyone have any ideas here? I still cant get into the BIOS, and I don't want to ship the board back without being sure its a board problem. One, because I've already got an OS on it, and two because shipping to Europe from the US is rather expensive.

  • MirchelMirchel New Member Posts: 2

    Hello. Have same issue. I just started to use UpCore + UPC-CRSTH-A20-0001 carrier board. I connected 7" TFT display using HDMI cable. I use usb keyboard and microSD card as boot device.
    I can see only bootsplash UpCore and screen to enter password. I can not enter any symbols to password string.
    Once i saw ubuntu boot menu and also keyboard worked so i could select items in menu. But it was only once.
    There is no any user manual, there us no UpCore connectors description.....well one of the worse documented project.
    So i'd like to ask UpCore officials:
    1. Which way bios decide to show password enter screen? May be BIOS first try to find any suitable boot device and if there is no, then it ask password to BIOS. Am i right?
    2. Why usb keyboard work so unstable?I use DEXP K-10002 keyboard....it run in Windows OS, in Linux OS, but not with UpCore. What can be reason of that?
    3. What boot source can be in UpCore? Can i use microSD slot or USB2 connectors in carrier board to connect usb reader with microSD card?
    Thanks

  • rogertsai(AAEON)rogertsai(AAEON) New Member Posts: 188 ✭✭✭

    @Mirchel

    1. Which way bios decide to show password enter screen? May be BIOS first try to find any suitable boot device and if there is no, then it ask password to BIOS. Am i right?
    2. Why usb keyboard work so unstable?I use DEXP K-10002 keyboard....it run in Windows OS, in Linux OS, but not with UpCore. What can be reason of that?
    3. What boot source can be in UpCore? Can i use microSD slot or USB2 connectors in carrier board to connect usb reader with microSD card?

    1. Yes, if bios can't find any bootable devices, the system will enter the BIOS Setup (password enter screen)
    2. Possibly compatibility issue with usb dongle, usb hub or other. Please try aother keyboard, or hub
    3. Yes, you can install OS on both of them. Besides, I would recommend to you to use a microSD card (SD3.0) on the carrier board, because you'll want to get a system with a higher speed data transfer. MicroSD slot is SD3.0 (SDR104, 104MB/s), but USB2 connectors is USB2.0 (60MB/s)

Sign In or Register to comment.