Both Realtek and Up-wireless dongle (LB-Link) will not maintain a connection

CliffRCliffR Posts: 10New Member

I have two Up boards with ubilinux. I have tried the Realtek and the UP-Store wireless dongle. Both exhibit the same problem. They will both show a connection as per Connman, but will not transmit or receive data after a very short period (2 minutes). I have to use connman to disconnect the wireless, then re-connec it. It works for 2 minutes then drops the service.
Anyone else have this problem?

Comments

  • Javier ArteagaJavier Arteaga Posts: 163Emutex mod

    Hi CliffR,

    Could you please PM me the output of this troubleshooting script (while the dongle is plugged in)?
    https://wiki.up-community.org/Software#Requesting_support_for_Linux_OS

  • CliffRCliffR Posts: 10New Member

    Thanks for looking at this.
    Very important to my company.
    Cliff

  • CliffRCliffR Posts: 10New Member

    Not sure why I did not get an email notification of your response. I would have answered immediately. I'll make sure profile is correct.

  • CliffRCliffR Posts: 10New Member

    I am on another network now and am not experiencing drops. Possibly the wifi is stable on secure networks (password auth). The previous network with the wifi dropping had no security.

  • CliffRCliffR Posts: 10New Member

    I did a fresh install of ubilinux with update and upgrade on UpBoard. The wifi adapter still fails after a short period of time and needs to be restarted with Conman. This is a serious issue. Attached is the debug log as requested. I did get an error from the debug script but do not know if it is important: tail: cannot open '/sys/kernel/debug/regmap/AA/' for reading: No such file or directory

    I had to restart the wifi during this comment.....

    Please assist. Thank you,
    Cliff

  • CliffRCliffR Posts: 10New Member

    ENet interface does not fail. A continuous ping from the board to my router will keep the wifi connection alive. Shorty after stopping the ping, or after no activity on FireFox, the wifi will die. I have to restart in Conman. About 30% of the received packets are discarded. I turned off power saving using the desktop tool, I'm not sure how to verify, as it still goes into screen saver.

  • CliffRCliffR Posts: 10New Member

    OK, I have a solution. I am on ubilinux on the UpBoard. DO NOT use a Realtek or the UPBoard store wireless dongle. They will drop connections on some networks. I tested several other dongles, and the "Panda Wireless Mini Wifi N USB Adapter" works!! It is plug and play, no drives to install.

Sign In or Register to comment.