BIOS does not show EMMC in boot options

yugendrayugendra New Member Posts: 4

I have loaded "ubuntu-16.04.3-server-amd64" on Emmc of UP2 board.I want to select EMMC as my boot option 1 but not able to see it in boot options. Can some one pls help me

Tagged:

Best Answers

  • Troy LinTroy Lin Posts: 29 admin
    Accepted Answer

    Hi Yugendra,

    The EMMC is in the BOOT selection of the BIOS menu as below picture
    If the EMMC is empty without any OS installed, it will just show Hard Disk
    If the EMMC is installed with Linux or Windows, it will show Hard Disk: Linus/Windows
    Please double check if that is the case on your UP2 board.

    Thank you.

Answers

  • Javier ArteagaJavier Arteaga Emutex Posts: 163 mod

    Hi yugendra,

    By loaded, do you mean you managed to successfully run the Ubuntu installer on your board?

    In any case, please check the BIOS settings as shown in this thread:
    https://forum.up-community.org/discussion/comment/7707#Comment_7707

    If you can see the eMMC device on that BIOS menu, it's likely an issue with the bootloader installation. If you can't, please let us know so we can arrange next steps.

  • yugendrayugendra New Member Posts: 4

    Hi Javier,

    Thanks for the response, i managed to successfully run the Ubuntu installer on the board. when i boot onto the board using ubuntu on USB, i am able to see that the emmc getting mounted as SD card & consisting of the root file system.

    I don't see the BIOS settings that you have mentioned above. i am sharing the option's which i'm seeing.

    Chipset option's :

    SCC Configuration Options:

    Also, i'm not getting the administrator level privileges in BIOS

    Main options:

  • yugendrayugendra New Member Posts: 4

    Hi ,

    The emmc is not getting detected in BIOS on up2 board, can some one pls help me, i have posted the images in above message

  • yugendrayugendra New Member Posts: 4

    Hi javier & Troy

    Thanks for all the help, as javier said after installing the GRUB i can boot into Ubuntu now from emmc

  • tlntutlntu New Member Posts: 2

    @yugendra said:
    Hi javier & Troy

    Thanks for all the help, as javier said after installing the GRUB i can boot into Ubuntu now from emmc

    Hi @yugendra,

    May I know how you fix this problem? I have the same exact issue as yours.

    Thanks.

  • tlntutlntu New Member Posts: 2

    Hi Javier,

    Everything's fine now after I reinstall using "Erase disk and install Linux" option instead of manual self partitioning.

    Thanks anyway. 😄

  • sharishari New Member Posts: 1

    Hello, I have the same problem and can not solve it. On which device should I install the GRUB? /dev/mmcblk0? /dev/sda?

  • ccaldeccalde Administrator, Moderator, Emutex Posts: 266 admin

    Hi all,

    Is that discussion solved?

    To avoid issues during the installation you must install using "Erase disk and install Linux" option instead of manual self partitioning, as @tintu said.

    @shari , you have to install Ubuntu over mmcblk0.

    Cheers!

  • s_ernos_erno New Member Posts: 1

    Hello!
    We have just bought an UP2 board and I would have liked to install an Ubuntu on it. Booted Ubuntu-16.04.3-desktop-amd64 image from usb drive in UEFI mode. Installed without errors. And I'm having the same problem of the system not recognizing the install. Just boots into bios every time.
    So far I have checked the following:

    • In BIOS eMMC is present.
    • In BIOS no operating system shows on Hard Disk at Boot options - just Hard Disk.
    • Tried it multiple times with "Erase disk and Install Linux"
    • Installed onto mmcblk0
      Could you please help me with this? Thank you.
  • ccaldeccalde Administrator, Moderator, Emutex Posts: 266 admin

    Hi @s_erno ,

    So, when you install your ISO for Ubuntu 16 Desktop you don't get any error, right?
    Then, the installation finishes successfully and you wait to remove your USB drive before reboot...

    Did you try with other OS? To be sure the issue is with the board...

    Thank you!

Sign In or Register to comment.