Can't install driver package provided in Downloads

airide101airide101 New Member Posts: 1

Whenever I go into the driver folder that I downloaded, I open the "Step 1 - Chipset" folder and run the setup application. However, After clicking next and trying to start the download, it immediately gives me an error saying "The requested operation failed". When I check the log file that it provides it has an error that says "Unable to pre-install driver file : " naming the first driver file in the list: "MBI.inf".

So I guess that file isn't properly installing and it aborts the install operation but I don't get it. Now what the hell do I do? They were the files that were provided in the Downloads section and all I did was install Windows 10. Did anyone have success installing drivers for Up Core?

Tagged:

Comments

  • AbsCodeAbsCode New Member Posts: 1

    I had the same problem with the Up Board driver install. Looks like it's a horribly written installer -- nice job Intel.

    If there is a space in the path, I experience this failure. When I made sure there was no spaces in the path, the install works just fine.

  • LasseLasse New Member Posts: 5

    Oh well..... doesn't look like UP ever tested their driver package. The spaces are already included in the zipped folder structure. The missing signature in the dummy driver isn't very professional either.

  • AlingAling Administrator, AAEON, UP reseller Posts: 507 admin

    Thanks for the feedback. Our team tested again and realized that one driver was missing. We just add a Hub driver for UP Core. https://downloads.up-community.org/download/up-core-windows-drivers/

  • praetorian55praetorian55 New Member Posts: 4

    Hi Everyone - I'm a bit late to this party, but I believe I might have determined how to get around this issue with the chipset driver installation:

    I believe the quirk is that if the installation setup file is in too many nested folders it fails - The way it's organized in the .zip file doesn't help either. After extracting the path was something like:

    C:\Users\MyUser\Desktop\UP core Windows Driver 20180131\Step1-Chipset\WIN10_64\setup.exe

    I copied just the "WIN10_64" folder directly to the desktop and the installation worked fine.
    (Path was then: c:\users\myuser\desktop\WIN10_64\setup.exe, which was two less folders deep)

    From there, the installation went off without a hitch - I tested this process twice and it worked both times.

Sign In or Register to comment.