First Impressions, not great but its early days.

Brian BeukenBrian Beuken New Member Posts: 35
edited December 2017 in OSes & Installation
Now that I have it up and running, I thought I'd outline my 1st impressions

Sadly not good.

Its very very slow, I mean very slow, Mouse dragging and visible screen update would suggest a total lack of of GPU acceleration.
Firefox, crashes, and in the process the mouse becomes unusable.
Any window is very slow to open, and again the visible screen update is apparent.

apt-get update && apt-get upgrade worked fine, but no change to performance.

No OpenGL or OpenGLES drivers on board, so I apt-get mesa drivers and gdb again connection worked fine if a little slow (I'm using a USB hub with an RJ45 to a switch)

Hooking it up to a VisualGDB test project on my PC, it appeared to be unable to make use of multi core/job handling running out of virtual memory on -j4,hanging on -j2 but eventually compiling on -j1
When I say compiling I mean very very slow compiling, and even then it locked up 8 files or so in, eventually throwing an unspecified compiler error, but with the board clearly still working on a task, as the mouse maintained its unusable drag. I can't see anything odd in the file it failed to compile.

Never got the test project to build so can't say what its performance is like.

I ran the same test project immediately on an Up^2 just changing the ssh target IP, and the project compiled and ran (albeit with some shader issues I need to get my head round). It compiled and ran at blistering speed.

I am using the as supplied version of ubilinx on the eMMC, has there been an update I can use (nothing listed on the UpCore downloads) that might correct these issues?

It is early days of course so this may just be the result of a 1st version of ubilinux on the board running sub optimal, but its a little worrying that my dual core celeron Up^2 has such a markedly better performance isn't it?

Comments

  • Brian BeukenBrian Beuken New Member Posts: 35

    Ok I need someone from Up to help here, this unit is either faulty or the software (ubilinux) needs a total upgrade.

    Please point me to info on how to upgrade the eMMC with a newer version and info on upgrading the Bios so I can get more than one core working

Sign In or Register to comment.