Installation of ROS Kinetic on v4 (Dolcetto)

Justin HuntingtonJustin Huntington Posts: 1New Member
This might be a long shot to find other ROS users on here, but I'm compelled to try.

I'm having trouble installing ROS kinetic on the new release of Ubilinux. I had it successfully running in several systems on ver 3, but a file system corruption on one particular unit prompted me to try the upgrade.

I've tried the standard method of installing using apt, as detailed here after setting up the sources.list.d/ubilinux-dolcetto.list sources list to bring in the debian jessie lists. The key I'm using for the keyserver is the one beginning with 412. Updating apt seems to source everything without incident. When doing the apt-get install ros-kinetic-whatever, I get an error indicating unmet dependencies, even for packages I've installed individually. Other packages unrelated to ROS install without incident using apt.

I then tried the python method of installing everything with pip(similar to what's going on here without the RPi specific items), including rosdep, and then running rosdep update, but I get an error indicating the script can't detect the OS, and I'm not sure where to start hunting to figure out what the script is looking at to determine the OS to make needed fixes.

I'd love to hear any guidance; I'd really love to hear about successful installations with the new version of Ubilinux. Maybe an intrepid and helpful person at emutex would be willing to give this a shot?

Comments

  • Nicola LunghiNicola Lunghi Posts: 131Emutex mod
    edited December 2017
    You could try to install it on ubuntu xenial

    we have just released a kernel for Ubuntu xenial (we need to update the documentation sorry but we are tyed up with other projects at the moment)

    please follow the instruction about how to install it here

    https://up-community.org/wiki/Ubuntu#UP_.2F_UP.5E2_.2F_UP_CORE

    If you want to share/create a tutorial about how to install ROS on up / up ^2 / up core we can put it on the wiki.

    Regards
    Nicola Lunghi
Sign In or Register to comment.