OS support for M.2 2230-Intel WIFI

BorislavBorislav New Member Posts: 2
I received my Ultra Starter Package several weeks ago. I tried to run wireless only system via the included WIFI card, but I'm unable to get it working. A few minutes after reboot the connection gets unstable and then the card goes offline with microcode errors in dmesg. I tried both ubilinux and Ubunto with latest kernels. Did anyone managed to get this working and if so on what OS/kernel version?
Thanks

Comments

  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    Hi Bobsana
    Can you please give us the card model/manufacturer?
    Also please submit us the output of the sysinfo script as explained here:

    https://up-community.org/wiki/Software#Requesting_support_for_Linux_OS

    Please use ubilinux 4 to do the test.
    Thanks
    Nicola Lunghi
  • David RolfeDavid Rolfe New Member Posts: 98
    Hi Bobsana,

    In reply to your question, I am using the supplied 'official' Wi-Fi card in my UP squared, (updated to BIOS 2.1) running the release version of Ubuntu 17.10 which recognised the card immediately, and sorted out the necessary drivers etc without any further input from me at all.

    The connection has remained constant, and I have not experienced dropped connections.

    Hopefully the advice given by Nicola in her post will assist you however.
  • BorislavBorislav New Member Posts: 2
    edited November 2017
    I'm sorry for late reply, I had some other things on my head.

    [edit] The card is the one I received as part of the "UP² Pentium Ultra Starter Package", I suppose it's M.2 2230-Intel WIFI 802.11ac+Bluetooth4.2

    I'm running Ubilinux from external SATA hard disk (nothing on the emmc). Attached are two sysinfo dumps from two restarts:

    sysinfo-after-hardware-reset:

    At about 741 second in dmesg I get some errors and wifi connection stalls
    [  742.032105] iwlwifi 0000:04:00.0: Microcode SW error detected.  Restarting 0x2000000.
    [  742.040887] iwlwifi 0000:04:00.0: CSR values:
    [  742.045781] iwlwifi 0000:04:00.0: (2nd byte of CSR_INT_COALESCING is CSR_INT_PERIODIC_REG)
    

    sysinfo-emmc:

    This does not happer every time but it's quite frequently (once every 3-4 reboots). I'm not sure if it's related to the wlan issue.
    [    3.285385] mmc0: mmc_select_hs200 failed, error -84
    [    3.285675] mmc0: error -84 whilst initialising MMC card
    
  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    Hi
    Found this on Ubuntu Launchpad bug list

    https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1694547
    https://bugzilla.kernel.org/show_bug.cgi?id=195945#c8

    could be the same issue?
    If it is please file a bug report on kernel mailing list and post here the link so we can follow the issue

    Regards
    Nicola Lunghi
Sign In or Register to comment.