Up-Board UEFI Bios upgrade

Kris GunnarssonKris Gunnarsson New Member Posts: 2
I have (I hope) a simple question: What does it mean:
"Put files from BIOS package into UEFI bootable USB drive."

I am trying to install ubuntu 16.04 onto an Up-Board (part of the Realsense kit).
I have failed everything I've tried; 16.04 will not "stick" to the Up-Board, i.e. will not boot w/o USB stick inserted.
I figured I needed to upgrade the UEFI bios(?).

I have created a 16.04.3 image on a USB stick using Rufus.
If I unzip upc1bm0x_efi.zip then copy the content of the UPC1BM0X directory onto that USB stick, there will be conflicts, i.e. over writing of files.

I am presumably not understanding the instructions correctly.
I will be very grateful for help.

Thank you,
-Kris

Comments

  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    Hi Kris
    please follow the guide on the UP wiki

    https://up-community.org/wiki/Bios_Update#Procedure

    Regards
    Nicola Lunghi
  • Kris GunnarssonKris Gunnarsson New Member Posts: 2
    edited November 2017
    [CORRECTION 171114 (2017Nov14)]
    "go_64.sh" was wrong, "go_64.nsh" is correct (see below)
    Thanks to charlybegood who pointed this out.


    Thank you for your response.
    In the meantime I had seen posts where others suggested following the Wiki so per your advice I did.
    It worked, I successfully installed 16.04.3.
    Thank you.

    In case somebody else has this problem (likely) I'll add my experience to make it less confusing for the next fella.

    I prepared a USB stick with only the UEFI Bios upgrade as instructed;
    I got to the Boot Menu, but my menu looked different from the one shown on the Wiki.
    I had only two options, the UEFI and Setup. I picked UEFI.
    This put me into a cycle where the board would boot up again and again.
    I was eventually able to catch it with the Esc key and get to the UEFI shell.
    However, the output scrolled by so fast that I was unable to see the drive letter that I should switch to.
    I tried different drive letters and "fs0:" worked for me.
    I then ran "go_64.nsh".
    This took a bit of time.
    I had to issue the reset command.

    Next time the board booted up I entered the Setup and was not too happy to see under the boot tab I still had the
    two option "OS Image" of Windows and Antroid. I wasn't sure if that was right.

    But I figured I should give it a try anyway and try to install 16.04, so I re-started the process.
    Miscellaneous info: I had the network cable disconnected; I chose to clean memory then install ubuntu;
    I chose no 3rd party stuff; I chose to force UEFI boot install; etc., etc.
    I don't remember any more drama.
    Bottom line was that to my great relief the install succeeded.
    Only took me 2.5 days to get it done!

    I hope the next guy who trips over this, finds this post and it helps him out.
    Good luck.

    -Kris
  • Charles DCharles D New Member Posts: 1
    Hi !
    I started to get crazy thinking there was a problem with my bootable USB drive but I found out that there is an error in your latest BIOS update files for UP board :
    > EFI/BOOT/startup.nsh
    you need to replace "go_nsh" to "go_64.nsh"
Sign In or Register to comment.