USB ports powered while the board is off - can this be disabled in the BIOS?

RussellRussell New Member Posts: 20
Hello,

I'm hoping there's a way to disable the USB ports supplying power while the board is off (but plugged in).
I had a look in the bios settings and don't think I saw the option, however I've seen it show up with other Intel based boards, so I'm hoping I've just missed it?

Cheers
Russell

Comments

  • DrewDrew New Member Posts: 6
    I'm interested in this feature too, and I was also unsuccessful in locating any controls in the BIOS .
  • eduncan911eduncan911 Administrator, Moderator Posts: 157 admin
    I kind of like this feature myself as I am building a simple KVM from a raspberry pi zero w that will always be powered on, in case my UP^2 needs a reboot.

    Form memory, that hasn't been an option I've seen in most Asus or ASRock BIOS's of late.

    Eric Duncan - UP Evangelist - My thoughts are of my own free will

    Answered? Please remember to mark the posted answered to highlight it for future visitors!

  • rogertsai(AAEON)rogertsai(AAEON) New Member Posts: 141 ✭✭✭
    edited October 2017
    I think this is not an BIOS setting, it's an OS setting.
    please follow the two steps to solve your issue, if you're using Windows 10

    Step1,
    Go to Control Panel > Power Options > Change Settings Scheme > Change Advanced Power Settings
    > USB Settings > and deactivate Selective Suspension (see below)


    Step2,
    Go to Control Panel > Power Options > Choose What Power Buttons Do > Activate Settings Currentlly Unavailable > Scroll down to Shutdown Settings > disable to Turn on fast startup item (see below VOD)
    [video]
  • DrewDrew New Member Posts: 6
    Thanks for following up, roger1tsai. However, I disabled selective suspend, and I turned off Fast Start, as indicated. Rebooted to confirm things had taken effect. Unfortunately, the USB port still seems to be active, as my USB-powered LCD is still showing up with full white backlight when plugged into an Up Squared that has shutdown. I unplugged HDMI to confirm it wasn't somehow powered via that connection, and it's still lit up.
  • RussellRussell New Member Posts: 20
    Hi Roger, thanks for the info. I'm using Ubilinux though, is there by any chance a similar procedure available for Ubilinux?

    Cheers
    Russell
  • Jesse KaukonenJesse Kaukonen New Member Posts: 42 ✭✭
    edited November 2017
    This is also something we require on the ubilinux. It's sometimes necessary to reboot USB devices completely, and it would seem doing a simple reboot does not cut the power to all USB devices. Unplugging power isn't always an option if the device is running somewhere remotely.

    It would also be enough if there was some command to disable the USB ports via the operating system.

    Edit: I now noticed this was in the UpSquared subforum. I'm on the default UpBoard, but I suppose this one is applicable to both boards.
Sign In or Register to comment.