Another Ubilinux installation query on UP2 board?

David RolfeDavid Rolfe New Member Posts: 98
Hi,

Sorry for yet another question, but I thought I would start afresh by preparing a new USB ‘stick’ (using Windows 10 on my PC), from which I plan to install Ubilinux on my UP2, on which I have already updated the BIOS to version 2.1.

The only image I can find for Ubilinux is an ‘iso’ file, which Rufus doesn’t seem to want to use for creating a boot disk, using the recommended ‘dd’ option, as it is expecting to find an ‘img’ file, which doesn’t appear to be available!

I want to have the 'Partition scheme' option set to “MBR partition scheme for UEFI” rather than “MBR partition scheme for BIOS or UEFI” so as to hopefully prevent any potential problems later.

Any help or guidance as to how I should proceed would therefore be very much appreciated.

Thanks!

Comments

  • WereCatfWereCatf New Member Posts: 201
    Just select the filter as "All files" instead of "DD Image" and select the ISO-file. Rufus doesn't care. Besides, writing the image as either an ISO-image or a DD-image doesn't matter, either, as they both work fine. I wrote the image as an ISO-image myself and had no trouble installing Ubilinux on my board from that -- I do not know why the Wiki tells you to use DD-image mode; maybe it was for older Ubilinux and they just haven't updated it?
  • David RolfeDavid Rolfe New Member Posts: 98
    Thanks, but I had already tried that, and Rufus wanted to change the "Partition Scheme", although when I did change it back to UEFI ony, leaving the image as an ISO one, a little box appeared asking me if I did in fact want to use the DD option.

    I did try using both options, but in neither case was my USB drive recognised as a boot device, so my UP2 board may not have liked the Kingston stick. In desperation I tried using a San Disk one I had prepared some time ago, and suddenly I was able to install Ubilinux... with which I am not particularly impressed!

    What I am now looking for is another easy to install (under UEFI) Linux derivative... preferably with a Gnome desktop to replace Uilinux... any suggestions?
  • WereCatfWereCatf New Member Posts: 201
    What, in your opinion, is so wrong with Ubilinux, then? The desktop-environment it ships with? Or you don't like Debian 9?
  • David RolfeDavid Rolfe New Member Posts: 98
    OK... well I couldn't see a quick or easy way to add other programs or applications. Shortcuts to things like system Information, or even a File Manager were not obvious to me, and I was expecting to see a few more menu options!

    Perhaps folk who are regular Linux users might feel more at home with it, but I'm afraid to say that I didn't.

    I am probably a bit more used to distros like Linux Mint, or even Antergos, so I am hoping there might be a few other alternative I could check out, which won't be too much of a pain to install.

    As you have probably guessed, I come from a 'Windows' background, which probably doesn't really help, but I do have a lot of respect for Linux based systems, hence my desire to install one on my UP2.
  • WereCatfWereCatf New Member Posts: 201
    Well, if you're less used to Linux I can see why you'd be upset with Ubilinux. The thing is, you can remove the currently-installed desktop-environment and install e.g. GNOME, all without having to ditch Ubilinux entirely. If you want to try something different I'd recommend trying Ubuntu 17.10 beta (the final, non-beta version is scheduled to be released in 9 days) as it has a very recent kernel and GNOME as its desktop-environment, but you'll lose access to the GPIO-stuff.

    Another option is to wait a few hours and I'll try to provide instructions on how to install GNOME under Ubilinux instead -- I'm playing Divinity: Original Sin 2 at the moment and I don't quite want to quit just yet :P
  • David RolfeDavid Rolfe New Member Posts: 98
    Thanks very much for the offers, which I very much appreciate, but I certainly don't wish to interrupt your Divinity Original Sin 2 session!

    I must confess I had been looking at Ubuntu 17.10, but wan't sure if it would be fully compatible with my UP2 board, although I am not particularly bothered about the GPIO 'stuff' at the moment.

    Will probably go and watch a bit of TV now, but if you do have time later to give me a bit of guidance, that would be great, as I might just have a look at GNOME on Ubilinux first, while it is still installed.

    Presumably if I were then to install Ubuntu afterwards, it would give me the option of 'overwriting' Ubilinux completely?
  • WereCatfWereCatf New Member Posts: 201
    Getting GNOME installed on Ubilinux and removing the current desktop-environment (called LXQT) is a bit of a mess, but here goes:

    You shouldn't be doing this over e.g. SSH, do this on a physically-connected display and keyboard. Switch to a console with e.g. CTRL+ALT+F3, log in with your normal user-account, and issue
    sudo apt -y install network-manager
    
    -- GNOME uses a different tool to set up networking than LXQT, so we need to install that first. Proceed to issue
    sudo apt -y purge connman
    
    and then use
    sudo nmtui
    
    to set up your networking, if it stopped working. (Try e.g.
    ping -c 3 google.com
    
    to check if it's still working or not)

    Now comes the part where you actually remove LXQT and install GNOME:
    sudo apt update && sudo apt -y install sudo && sudo apt -y purge sddm lxqt task-lxqt-desktop liblxqt0 lxqt-common lxqt-session && sudo apt -y install task-gnome-desktop && sudo apt -y autoremove
    
    -- this will take a good while as there are a lot of packages to install.

    If it didn't spit out an error you should be fine with
    sudo reboot
    
    and free to explore GNOME. (Disclaimer: I didn't actually test if everything works right or not, I'm tired and I want to go to bed.)
  • David RolfeDavid Rolfe New Member Posts: 98
    Hi,

    Apologies for not thanking you earlier for the above details, which worked well until I tried to set up my networking again, which had indeed stopped working, as 'pinging' Google informed me of a 'temporary failure in name resolution, and it didn't seem interested in reconnecting!

    Being a bit impatient, I then decided to try an installation of Ubuntu 17.10 ... yes, I know that a Release Candidate is due to be launched today, and the final version on 19th October, but I was keen to give it a go anyway.

    Much to my surprise, everything went extremely well, without any error messages appearing at all, so I will be detailing my experiences in a separate thread, which I hope will be of interest!

    I know that it is not for everyone, but my advice for now, to those who are not overly concerned about GPIO 'stuff' and that sort of thing, is to give Ubuntu 17.10 a try, and I think that (like I was!) you will be pleasantly surprised.
Sign In or Register to comment.