This is the area to clarify hardware specification if there's anything unclear from the datasheet. If the specification is software related, please ask in the related software section.

Up2 MP 8G/128G emmc speed issue

BartekBartek Posts: 16New Member
Hello,

I have UP 2 8/128G version. Emmc chip is samsung KLMDG8JENB, so it should work as HS400. However my board is able to boot only in mode DDR50!

Here is the error with HS400 and HS200:
mmc0: mmc_select_hs200 failed, error -84
mmc0: error -84 whilst initialising MMC card
The problem with DDR50 I is that it is very slow as main drive. It is getting 73-74 MB/s. But system is stable.
I have newest version of ubilinux and updated bios. I am posting some screenshot. The emmc error after boot is not visible on uart console, so I had to make a photo of the screen.I have sent a message to up, and they told me to post my problem on this forum. Thanks tor any help.

Regards
Bartek

Comments

  • BartekBartek Posts: 16New Member
    @UP Support:
    It has been already 3 since I reported this issue! Topic is started for 2 weeks and still no info from you? Shall I send back to you the board as warranty claim?

    Regards
    Batek
  • BartekBartek Posts: 16New Member
    edited October 2017
    Hello,

    have tested windows 10 on my board, and it worked well using HS400 setting. Speed test gave me more than 3x faster results than in ubilinux in DDR50!

    After reinstalling ubilinux I still got the same error.
    Now I am using ubilinux installed on external ssd, and emmc is not visible in HS400 mode. There was an error during boot:
    [    3.098461] mmc0: mmc_select_hs200 failed, error -84
    [    3.098764] mmc0: error -84 whilst initialising MMC card
    [    3.236992] ata2: SATA link down (SStatus 4 SControl 300)
    [    3.241592] ata1: SATA link down (SStatus 4 SControl 300)
    [    3.278130] mmc0: mmc_select_hs200 failed, error -84
    [    3.278435] mmc0: error -84 whilst initialising MMC card
    [    3.468454] mmc0: mmc_select_hs200 failed, error -84
    [    3.468796] mmc0: error -84 whilst initialising MMC card
    [    3.588928] clocksource: Switched to clocksource tsc
    [    3.712550] mmc0: mmc_select_hs200 failed, error -84
    [    3.712853] mmc0: error -84 whilst initialising MMC card
    

    Doing fdisk -l doesn't show internal card. Emmc is only visible in DDR50 mode.

    Why it works ok in windows 10, and in dedicated OS does not?
    I have tried downgrading bios to version 18, and then again 21. Resetting bios didn't helped also.


    Regards
    Bartek
  • BartekBartek Posts: 16New Member
    Hello,

    I tested the board using Ubuntu 16.04 and emmc works fine in mode HS400:
    /dev/mmcblk0:
     Timing buffered disk reads: 786 MB in  3.00 seconds = 261.67 MB/sec
    

    So the problem is with Ubilinux4. I have just stop using it since gpio are suppored in Ubuntu.

    Maybe my post will help someone.

    Regards
Sign In or Register to comment.