Crashes with Ubilinux and no ALSA sound with Debian9.1 (32&64bit)

Ingo ScherzingerIngo Scherzinger New Member Posts: 7
Hi everybody,

I'm trying to run a rather complex PureData patch on an Up Board (x5-Z8350 CPU,32GB eMMC, 4GB RAM).
After spending a lot of time with ubilinux and the normal debian9.1 (64bit) I couldn't stop it from constantly crashing when I opened my patch - for some unknown reason. Probably a 64bit compatibility issue with some external libraries.
As long as I was using ubilinux sound (alsa) was working at least. Not so with debian, though.

After giving up with the 64bit OS I installed debian 9.1 (32bit) and it's running perfectly stable as before with my old amd hardware. No more crashes!
However, with the normal Debian ALSA is NOT giving me any sound!

Then I compiled the kernel with oss but oss is not producing any sound either.

I installed alsa-utils, alsa-base and alsa-tools-gui.
I removed pulseaudio and I made sure alsa-utils would get started on startup (which it doesn't by default on the LXE desktop).


Here is what I get from Pd when I activate ALSA as the sound system:

ALSA input error (snd_pcm_open): No such file or directory
ALSA output error (snd_pcm_open): No such file or directory

The (external USB-)sound card does show up in the drop down menu of Pd's audio settings for selection, though.
So it is recognized both by Pd and the operating system. I tried several different USB sound cards with the same result.

Here is what I get when I try to open alsamixer from the LXTerminal:

"error when opening mixer: No such file or directory"


When I use portaudio I'm actually getting sound but it is very quiet as the sound output is turned down by the system during start up. I can't find any way to turn the volume of the sound card up, though since I cannot open any mixer.

Does anybody have an idea how I can get alsa to work?
Debian tells me that "alsa-utils" and "alsa-base" is already installed with the newest version (1.1.3-1 and 1.0.27+1).

Since there is no 32bit version of Ubilinux I forced to use Debian (32bit) in order to avoid crashes.


Thanks, Ingo

Comments

Sign In or Register to comment.