How to update the BIOS to the current upc1bm0x version

Ingo ScherzingerIngo Scherzinger New Member Posts: 7
Hi,

I have tried to update my Up Board (32/4GB) BIOS without any success. The instructions don't make any sense to me.
Are there any instructions that do make sense?

I have downloaded "upc1bm0x_efi.zip" and unpacked it to "upc1bm0x_efi".

Now my question is:
Do all files inside this folder "upc1bm0x_efi" need to be copied onto the top level of the bootable USB drive that I have created with rufus 2.17 as a FreeDOS system? Or is it the folder itself or the content of the "UPC1BM0X" folder inside of the latter folder?

When I boot into this I get a list but the instructions do not tell me how to do anything that would come near updating the BIOS.

If anyone can give me an idea about which files need to be on the drive and which command to input for a 64bit BIOS update I'd be very greatful.

Thanks a lot!
Ingo

Comments

  • Nicola LunghiNicola Lunghi Emutex Posts: 131 mod
    Hi
    please follow the procedure here: https://up-community.org/wiki/Bios_Update
    in particular:
    *format the usb as a fat32 system (no freedos, no rufus)
    *extract the content of the zip on the formatted pendrive (not in a subfolder, on the root of the pendrive)
    then you should be see the USB disk on the boot menu
    Regards
    Nicola Lunghi
  • Ingo ScherzingerIngo Scherzinger New Member Posts: 7
    Thanks!
    Ill give it a try!
  • Ingo ScherzingerIngo Scherzinger New Member Posts: 7
    Thanks again, Nicola!
    Worked perfectly now.

    Why is there no link to that BIOS Update - UpWiki on the download page?
    Instead there is just a "very strange" description ...

    Life could be so much easier. :-)
  • Ingo ScherzingerIngo Scherzinger New Member Posts: 7
    OK, sorry I need to take that back!

    The BIOS Information still tells me that the BIOS is:

    UP-CHT01 R0.X (09/10/2016)

    That's still the OLD version. Why is that?
    It was executing the update. All columns said DONE.
    Then I had to type "reset" for rebooting.

    When I checked I found out that the BIOS had not been updated.
    Very STRANGE!!!

    I'll try once more ... :-(
  • Ingo ScherzingerIngo Scherzinger New Member Posts: 7
    Did it again and the BIOS has changed. Should be from 2017 but it says 2016. ?

    There might have been an old BIOS copy in the grub boot manager before since I had a standard Debian Stretch system installed which might have copied the BIOS during the installation to grub. Not sure ...

    So hopefully my problems with major crashes when using Pd has improved.
Sign In or Register to comment.