Share your project ideas and how you implement it.
If you already made something, tell us!

UP Squared Experience so far

Duane GoodmanDuane Goodman Posts: 33New Member
edited December 2017 in Unboxing & Project Sharing
Hey everyone

So I've had my UP^2 for a few days now and wanted to share my experiences so far. :) Overall I've got a few issues I still need to fix before I can use it as a media center. Will also be using it as a web server and perhaps some minor gaming, but primarily as the media center.

Installation (Ubuntu): Had a little issue with my keyboard not being recognized in the installer, but found a workaround forcing the board into the boot menu (F7) then it works.

Kodi Media Center: Installed fairly easy and the board handles 4K media without breaking a sweat.

UP^2 Fan: Saw a video on Youtube claiming it was virtually silent, but mine is pretty noisy. I think I will have to look for some way to lower the speed or only run the fan when the CPU is getting hot. If not I will probably switch it back to the heatsink.

Audio: Sound is only working directly to the TV. HDMI ARC to our surround sound turns off the moment I power on the board. All other devices work fine (Raspberry Pi, Playstation 4 etc.). As soon as I power off the board, ARC enables itself again. Haven't found any resolution for this yet.

HDMI CEC: Not working, no solution as of yet.

Comments

  • Duane GoodmanDuane Goodman Posts: 33New Member
    So now I have updated to the version 21 BIOS/UEFI. I can no longer access the boot menu (F7 results in black screen). Bit concerning since this means I won't be able to acess the UEFI shell next time UP roll out an update.

    If I press Delete, then I can get into the BIOS and by exiting without saving changes boot up the OS. Keyboard still dosn't work if I just let the system operate by boot priority.

    Tried using lm-sensors yesterday to try and control the fan, but it doesn't recognize it. Finally I have found some ACPI fan settings in the BIOS, but I haven't tested these yet. CPU runs at 25 degress on low load and 40 degrees playing 4K video so it's completely overkill to run the fan at full RPM at those temperatures.
  • WereCatfWereCatf Posts: 201New Member
    Duane01 wrote:
    So now I have updated to the version 21 BIOS/UEFI. I can no longer access the boot menu (F7 results in black screen).

    Did you disable the administrator-password in BIOS? At least my board asks for the BIOS-password instead of giving me a black screen when I press F7 to bring up the menu, but I have not disabled the admin-password -- if you have disabled the password you may have found a bug in the BIOS, where it's showing a black screen when it normally would've asked for a user/admin password.
    Duane01 wrote:
    Keyboard still dosn't work if I just let the system operate by boot priority.

    Do you have XHCI hand-off enabled in BIOS? Disabling that caused issues with keyboard-recognition for me, keeping it enabled allows for it to work fine.
    Duane01 wrote:
    Tried using lm-sensors yesterday to try and control the fan, but it doesn't recognize it. Finally I have found some ACPI fan settings in the BIOS, but I haven't tested these yet. CPU runs at 25 degress on low load and 40 degrees playing 4K video so it's completely overkill to run the fan at full RPM at those temperatures.

    AFAIK there is no way of controlling the fan. At least that's what AlingWu told me; it's just passively connected to +5V and GND. This is also why I designed a HAT of my own that provides fan-speed control.
  • Simon GrønbækSimon Grønbæk Posts: 3New Member

    Any updates on the HDMI surround sound?

Sign In or Register to comment.