4K video - kills the UP Board

Hello,

I have couple UP Boards - heat sink version. Whenever I play video in 4K resolution board freezes after some short time.
Tried official ubuntu build also upgraded to 4.11 kernel. Makes no difference after 15-20 minutes board freezes and
require hard reboot.

to play video I run X11 + compton composition manager + mpv with hardware decoding :
[email protected]:~# mpv --fs --hwdec=auto --vo=opengl 4K.mp4
Playing: 4K.mp4
(+) Video --vid=1 (*) (h264 3840x2160 29.970fps)
Using hardware decoding (vaapi).
VO: [opengl] 3840x2160 vaapi[nv12]

Have tried official build for all of the above as well latest versions from edgers/testers repositories. No difference.

CPU Temperature reading goest up to "75C - 76C" according to lm_sensors.

It does not really matter if video 4K or 1080P or lower resolution. CPU utilisation for MPV is 18-25%. Overall CPU utilisation ~ 20%.

Anyone experience same problem ?

Comments

  • AlingAling Administrator, AAEON, UP reseller Posts: 522 admin
    Hi , Cherry Trail (UP board) can only does 30fps in 4K, and it makes the board very hot and frozen.
    We will suggest you adding an active cooler to reduce the heat. https://up-shop.org/up-peripherals/111-active-cooler-fan-for-the-up-board.html
  • Nikolay ArbuzovNikolay Arbuzov New Member Posts: 3
    Added fan. Did not fixed the problem. Board was still freezing after ~15 minutes. however temperature dropped to ~55C

    What seems made a difference is adding intel_idle.max_cstate=1 to kernel command line. At least it is still working showing 1080P content on 4K screen for little bit over an hour.

    Thanks.
Sign In or Register to comment.