UP Board and ZR300

VladislavVladislav Posts: 20New Member
edited August 2017 in MIPI-CSI
Will UP Board handle intel realsense ZR300 well?
Did anybody try to use it?

What is preferred: UP Board+ZR300 or Intel Euclid?

I found that Intel provides convinient standalone (no ROS) SLAM libraries for ZR300 so I intend to migrate from R200 to ZR300.

Comments

  • DCleriDCleri Posts: 520Administrator, Emutex admin
    Hi Vlad,

    the ZR300 has already been tested successfully by Intel on UP Board.

    It is available also on the UP Shop: http://up-shop.org/up-peripherals/118-realsense-zr300-camera.html
  • VladislavVladislav Posts: 20New Member
    Hi dcleri!

    I just got zr300 and trying to set it up on ubilinux 3.0 on my upboard.

    I try to follow this instruction but it is about ubuntu 16.04.
    Ubilinux 3.0 is based on Debian Jessi, so I have some issues with package dependencies:
    $ sudo apt install librealsense-samples beignet-opencl-icd
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     beignet-opencl-icd : Depends: libdrm-intel1 (>= 2.4.60) but 2.4.58-2 is to be installed
                          Depends: libllvm3.7 but it is not installable
                          Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
     librealsense-samples : Depends: libopencv-core3.1 but it is not going to be installed
                            Depends: libopencv-highgui3.1 but it is not going to be installed
                            Depends: libopencv-imgproc3.1 but it is not going to be installed
                            Depends: librealsense-object-recognition0
                            Depends: librealsense-persontracking0 (>= 0.5.10) but it is not going to be installed
                            Depends: librealsense-sdk0 (>= 0.7.2) but it is not going to be installed
                            Depends: librealsense-slam2 but it is not going to be installed
                            Depends: librealsense1 (>= 1.9.7) but it is not going to be installed
                            Depends: libstdc++6 (>= 5.2) but 4.9.2-10 is to be installed
    E: Unable to correct problems, you have held broken packages.
    

    The question: how do you think, is it possible to install and use Intel's examples and SDK for SLAM library on Ubilinux?
  • DCleriDCleri Posts: 520Administrator, Emutex admin
    due to the libraries versions available on ubilinux 3.0 I would suggest to use the tutorial with Ubuntu 16.04 and install our custom kernel on top from the PPA repository.

    We are going to release within August ubilinux 4.0 based on Debian Stretch for all the UP boards and it might be easier to setup the ZR300 there.
Sign In or Register to comment.