UbiLinux 4 beta 2 installer

Jesse KaukonenJesse Kaukonen New Member Posts: 42 ✭✭
edited August 2017 in UP Squared Linux
Today I tested the ubilinux 4 beta 2 on my Up Squared. There were a couple of issues:

* I had issues with the board detecting USB sticks. I tried 3 at our office and none worked. I tried the following:
- dd the image onto the main device file (/dev/sdx). The board did not detect the stick. I attempted to mount the assorted partitions the EFI console displays, but no USB devices were found. The BIOS also found no USB sticks
- Manually formatted the USB stick and created a FAT16 partition, mounted the image and copied its contents to the FAT16 partition on the stick. Nothing was detected
- Bought a new stick from a local store, dd'ed the image onto the stick, the USB stick was successfully found. The new stick is a 16GB Kingston Datatraveller SE9. The non-working sticks are: 16GB "Extreme USB 3.0" SanDisk" and assorted older USB2 sticks on which I don't find any manufacturer notes. It should be noted the 16 GB SanDisk I had works with the standard Debian installer on my work laptop.


* The setup.sh suggests /dev/mmcblk0 as the default device. This seemingly doesn't exist on the UpSquared. The installation fails with the exit code ":(" which I think is printed from the output of "set -e". I'd recommend the output from the commands be properly printed to the user so that errors like that are more easily detected. I ended up ^z interrupting the script and manually executing the commands in the setup.sh to figure out what it is that was going wrong.
- Alternative change the setup script so that it lists the emmc partitions found under /dev and don't default to one that doesn't even exist


In addition, does this beta work with the standard UpBoard, or is it limited to UpBoard Squared for now?

Comments

Sign In or Register to comment.