Event 10016 DistributedCOM crashing Windows 10

Robert SheltonRobert Shelton New Member Posts: 109
edited August 2017 in OSes & Installation
Over the last couple of days I have experienced multiple crashes of my Up2 / Win 10 due to an 10016 DistributedCOM error. The system shuts down - no blue screen, just goes black. Each time I have difficulty restarting due to repeated crashes during restart. I have found that removing the DP connection allows the machine to restart successfully on the next try (I am using both an HDMI display and a second HDMI monitor via a DP to HDMI active converter). I also experienced, after system reboot, that Windows immediately crashed when I plugged in the DP adapter. After a couple of repair / reboot cycles, I could not use the DP. The direct HDMI display works fine. This further suggests that the problem is related to DP drivers.

Here is the detail from Event Viewer:

Log Name: System
Source: Microsoft-Windows-DistributedCOM
Date: 8/2/2017 2:18:45 PM
Event ID: 10016
Task Category: None
Level: Error
Keywords: Classic
User: LOCAL SERVICE
Computer: Up2
Description:
The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {6B3B8D23-FA8D-40B9-8DBD-B950333E2C52} and APPID {4839DDB7-58C2-48F5-8283-E1D1807D0D7D} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">;
<System>
<Provider Name="Microsoft-Windows-DistributedCOM" Guid="{1B562E86-B7AA-4131-BADC-B6F3A001407E}" EventSourceName="DCOM" />
<EventID Qualifiers="0">10016</EventID>
<Version>0</Version>
<Level>2</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x8080000000000000</Keywords>
<TimeCreated SystemTime="2017-08-02T18:18:45.705970900Z" />
<EventRecordID>7961</EventRecordID>
<Correlation />
<Execution ProcessID="836" ThreadID="1248" />
<Channel>System</Channel>
<Computer>Up2</Computer>
<Security UserID="S-1-5-19" />
</System>
<EventData>
<Data Name="param1">application-specific</Data>
<Data Name="param2">Local</Data>
<Data Name="param3">Activation</Data>
<Data Name="param4">{6B3B8D23-FA8D-40B9-8DBD-B950333E2C52}</Data>
<Data Name="param5">{4839DDB7-58C2-48F5-8283-E1D1807D0D7D}</Data>
<Data Name="param6">NT AUTHORITY</Data>
<Data Name="param7">LOCAL SERVICE</Data>
<Data Name="param8">S-1-5-19</Data>
<Data Name="param9">LocalHost (Using LRPC)</Data>
<Data Name="param10">Unavailable</Data>
<Data Name="param11">Unavailable</Data>
</EventData>
</Event>

This discussion seems promising: https://support.microsoft.com/en-us/kb/899965. I followed the link posted by DarekWa. The Microsoft article was written for XP, so I had to translate to Win10. When I got to the dcomcnfg part of the process, a couple of dialogues popped up indicating that the offending application was not recorded; and asking if I wanted to record it. I responded yes to both, although that isn't mentioned in the posts. The offending application is ShellServiceHost in my case. If your Security tab is greyed out in dcomcnfg, look carefully at the second page of the postings. You may need to give administrators full_control permissions to the key in the registry before proceeding to dcomcnfg. You may also need to change ownership of the application/key. In my case it was set to TrustedInstaller. I changed it to Administrators. Note this assumes your account is a member of Administrators. Don't forget to reboot after making registry changes.

R

Comments

  • Robert SheltonRobert Shelton New Member Posts: 109
    edited August 2017
    Problem may not be limited to the DP - may be more general to display subsystem. I have had the DP/secondary monitor disconnected since yesterday's events. My Up2 just crashed in the same way with only the HDMI/touchscreen operating. Also it failed to reboot on the first try, crashing as the Windows login screen displayed. Operating after the second reboot. Two errors in the System event log, both for the same DCOM permissions issue / application described previously.
  • Robert SheltonRobert Shelton New Member Posts: 109
    edited August 2017
    This Windows 10-specific post also is helpful if the Security tab remains greyed out after changing permissions in regedit: https://www.tenforums.com/general-support/31474-error-10016-a.html. Take note of the suggestion that more than one registry entry may exist for the offending application; and that ownership and permissions may need to be changed for multiple entries. In my case, a total of 2 entries required change. Once that was fixed, my "greyed out" problem was fixed. I was able to complete the steps specified in the first article for repairing the permissions problem.

    After checking permissions / completing the steps to the first-mentioned posts, my Up2 rebooted successfully and did not crash when I connected the second monitor via DP.
  • Robert SheltonRobert Shelton New Member Posts: 109
    This remains an open issue. The crashing is intermittent. Sometimes the Up2 crashes within seconds of plugging in the DP adapter to my secondary HDMI monitor. Other times is operates for a while but crashes when I trigger a complex display action (i.e. rendering a PPT as opposed to simply displaying the desktop or a file browser). I have tried multiple recommendations for solving this, but at this point the only way my Up2 is stable is running a single HDMI display. That's a major limitation for me, as my work requires the real estate provided by two full HDMI displays about 75% of the time.

    Has anyone else experienced problems with crashing / displays / DP or DP adapters?
  • Robert SheltonRobert Shelton New Member Posts: 109
    Probably solved - will continue to track.

    Unrelated to this issue, I bought a 5v 6A power supply from Up-store to replace the 5v 4A supply that ships with Up2. I had seen enough recommendations for 6A on the forum that this seemed like a sound course of action. The crashing behavior has not occurred since switching to the 6A supply.

    Association of crashes with 10016 was based on occurrence in the logs. I inferred causality - now, I believe, erroneously. I suspect that the total load of DP driving a monitor, HDMI driving a monitor, the HDMI monitor being powered from a USB port on the Up2 (it's a portable HDMI flat panel touch screen), WiFi / BT4 and (frequently) a secondary WiFi dongle ran the Up2 too close to the supply limit for the 4A supply. Crashes often seemed to follow complex operations that involved both displays; or other work-intensive activities. Power demand increases with CPU and GPU load, probably pushing my configuration over the 4A line. Note that I still see 10016 errors in the logs at about the same rate and for the same applications / registry keys as before - now without crashing.

    If my conclusion is correct, it would be advisable to ship the Up2 with a 6A power supply by default. The cost difference between the 4A and 6A bricks likely is minimal. Downside that the beefier supply would prevent: customers chasing intermittent hardware or software problems with the Up2. Market perception of product problems, however erroneously based, is more costly than the few cents per power supply difference. And my guess is that a sizeable percentage of the Up customer base works with more demanding configurations.
  • David RolfeDavid Rolfe New Member Posts: 98
    Wasn't it only the UP2 boards ordered through Kickstarter that came with a 4A power supply?

    I was under the (perhaps mistaken) impression that any boards pre-orders placed after the campaign had finished did not include a power supply, and that it was up to the customer to order a 6A one from the Shop if they didn't already have one available.

    I hope you have managed to solve your problem though!
  • Robert SheltonRobert Shelton New Member Posts: 109
    Hi @Montala - that may well be the case. Mine is from Kickstarter. Problem does seem to be solved.
Sign In or Register to comment.