UP2 Win10 - Audio not working

TobiTobi New Member Posts: 5
edited July 2017 in Audio
Hey all,

3 weeks after I got the new UP squared, I started today putting an OS on it. I have choosen Win10 Pro and installed it on the UP2 internal memory.

Afterwards, I downloaded and installed all Drivers, provided in the download area. But after installation, some devices are still not recognized in the device Manager (see attached Image).

Does anyone has an idea what devices this are?

Most strange is, that the Audio Controller is not installed. I thought, it was provided together with the Display Drivers (I am using HDMI). In the Display Driver Folder, there is a "DisplayAudio" Folder included but this Driver can not be used for the uninstalled Audio controller. Also during the Display Driver Installation via Setup, it tells me that just the graphic Driver will be installed. Nothing written about the Audio Driver.

Finally, I connected the UP2 to a Screen with Speakers but I dont have any Sound. In the Task bar, Audio Symbol is red crossed.

Does anyone have already experiences running Win10 on the UP2 and can help me here?

Comments

  • Rik de la RambeljeRik de la Rambelje AAEON Posts: 5
    edited July 2017
    Dear Tobitet,

    Just in case make sure you are running the latest BIOS version.

    If you switch from Ubilinux to Windows 10 or vice versa and you need audio over the HDMI you will also need to change the audio setting in BIOS, to do this:
    -Press DEL during boot.
    -It will ask for a bios password but you can leave this blank and press enter.

    -For audio in Windows:
    -Navigate to the “Chipset” Tab
    -Choose “South Bridge”
    -Choose “HD-Audio Configuration”
    -Set HD-Audio DSP to “[Disable]”

    -For audio in Linux:
    -Navigate to the “Chipset” Tab
    -Choose “South Bridge”
    -Choose “HD-Audio Configuration”
    -Set HD-Audio DSP to “[Enable]”
  • TobiTobi New Member Posts: 5
    Hi RikRambelje,

    thanks for that hint!

    I changed the bios Settings but afterwards it was still not working. Then I was reinstalling the chipset and the graphics Driver and after one more reboot I got Sound :-) Tanks a lot!

    Was that official documented and I´ve not seen it?
  • Dear Tobitet,

    I am unsure if it is in any official documentation. I can see it is not listed on the wiki page.
    I will check to see if we can add it there. Thanks
  • TobiTobi New Member Posts: 5
    This is for sure a good idea!
  • SallySally New Member Posts: 6
    This should definately be included in the official documentation. We shouldn't have to search forums for answers that we should have been told about right from opening the box the UP2 comes in.
  • These notes have now been added to the UP2 audio section on the wiki.

    Found here: https://up-community.org/wiki/Audio#HDMI_audio_2
  • Robert SheltonRobert Shelton New Member Posts: 109

    Thank you for these posts! My audio suddenly stopped working at some point. I don't often use audio on this machine, but found that the issue prevented use of ANY audio hardware - HDMI, USB external device, etc. BIOS setting fixed the problem. Again, Thanks!!

  • guruaswathguruaswath New Member Posts: 1

    @Rik de la Rambelje said:
    Dear Tobitet,

    Just in case make sure you are running the latest BIOS version.

    If you switch from Ubilinux to Windows 10 or vice versa and you need audio over the HDMI you will also need to change the audio setting in BIOS, to do this:
    -Press DEL during boot.
    -It will ask for a bios password but you can leave this blank and press enter.

    -For audio in Windows:
    -Navigate to the “Chipset” Tab
    -Choose “South Bridge”
    -Choose “HD-Audio Configuration”
    -Set HD-Audio DSP to “[Disable]”

    -For audio in Linux:
    -Navigate to the “Chipset” Tab
    -Choose “South Bridge”
    -Choose “HD-Audio Configuration”
    -Set HD-Audio DSP to “[Enable]”

    I tried these things and also updated device drives and i am using win 10 is there any solutions to fix:no audio problem

Sign In or Register to comment.