Initial Bios Release needed

TobiasTobias New Member Posts: 5
Hi everyone,

I own a up squared with 2Gb/16GB emmc. I bought the board for the use of a router with the german fli4l linux distribution.
At the start I had to figure out that fli4l cannot boot from uefi mode, so I changed the settings in the uefi to CSM enabled. The board was booting from usb stick.
After several problems with drivers and about 30 hours of work I managed to install the linux to the internal emmc. Everything was working fine.

Today I found out that you released a new uefi version (version 1.8). After reading the release notes I decided to flash it.
Now the board can't boot from the internal emmc, even if the csm option is enabled. The emmc is not showing up in the boot list, can't change the setting.
In the patch notes there was no sign that there was a change in the boot order and the csm module.

Please provide me a link to the old initial uefi version so I can flash it back and get it working again.

Thanks in advance.


  • DCleriDCleri Administrator, AAEON Posts: 1,101 admin
    edited July 2017
    Hi reddevil,

    I don't think you need to roll back your BIOS.

    Can you reset the BIOS and re-set the boot option to legacy mode?
  • TobiasTobias New Member Posts: 5
    At first I loaded the default values for the bios. Now the CSM was disabled, so I enabled it and set the video card and the storage to legacy. But the emmc entry doesn't show up in the boot menu. Also any legacy usb stick won't boot, only a uefi installation medium like windows 10 is working.
    At least I tried to reset the bios by removing the battery for 2 Minutes. CSM was again disabled, clock and date had also their default values. So I know the reset worked.
    But again I don't get the emmc showing up in the boot list.

    So I think there must be something changed. My last chance seems to revert the bios to the initial version.
  • TobiasTobias New Member Posts: 5

    I invested again several hours in configuring the UEFI and getting the CSM Module to work with the new UEFI Update. But there is no way. Only UEFI boot is working but this doesn't help me to get my router running.

    I reread your patch notes again and again but there is no hint whats you have changed in this direction.

    Since 4 days I am waiting for an answer and a possibility to revert to the initial UEFI or an update which activates the CMS again. So I'm getting a little bit angry.

    Can you please give me an answer how we can solve this?

    Thanks in advance.
  • DCleriDCleri Administrator, AAEON Posts: 1,101 admin
    Hi Reddevil,

    Thanks for your feedback and you findings

    I am sorry for your issue but we are currently investigating internally to see if we can fix it in the next BIOS release.

    Also, we are going to review internally if we can release the original BIOS and update you in the coming days.

  • TobiasTobias New Member Posts: 5

    I'm waiting now for 2 weeks but didn't got the actual status you promised me.
    Could you please provide me a solution. In the actual state the board is not usable for me.

  • JennyChenJennyChen AAEON Posts: 1 mod
    Hi Reddevil,
    Sorry for my late.
    we not prefer to release the old BIOS because of known issues that limit the system usability. AAEON cannot support the downgrade process due to the many changes in the new BIOS. The Legacy mode was never officially supported by Intel and it was available only for testing purposes, but it shouldn't be used in production systems.
  • TobiasTobias New Member Posts: 5
    Hi JennyChen,

    sorry but this is the worst joke I have ever heard.
    When I bought the board I didn't know if CSM was possible or not. But in the inital version you shipped legacy boot was working so I invested several weekends with compiling kernels and getting my linux distribution to a working state.

    And now the UEFI Update ruined everything. You didn't write anywhere that legacy is only for testing purposes. And I don't find any written word in the changelog that you changed this.
    Although this is for home purposes my time has a certain value.

    So I EXPECT A SOLUTION! I would exchange the board against an old one if i has the old UEFI version.
    Sorry again but your excuse don't help me.
Sign In or Register to comment.